Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

error persisting data to S3

Hey folks,
It looks like my setup is not correct. I get this error when i try to insert a record into a table.

How do i troubleshoot this ?
Anything wrong with the bucket?
02823bcda288a8811479d012e64c241d00c0000000000e10_0.gt]: Could not stat file [s3://BUCKET_NAME/communal/70c/02823bcda288a8811479d012e64c241d00c0000000000e10_0.gt]: Unable to parse ExceptionName: PermanentRedirect Message: The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.
2017-10-30 19:15:07.964 Init Session:7f4e218c0700-c000000000055c [Dist] Cleaning up Uploader on fail
2017-10-30 19:15:07.965 Init Session:7f4e218c0700-c000000000055c [Dist] Cleaning up Uploader on fail
2017-10-30 19:15:07.966 Init Session:7f4e218c0700-c000000000055c @v_verticadb_node0002: 58030/8162: Something went wrong while copying the files to persistent location.

Comments

  • Hi Colin,

    Please make sure you set AWSRegion configuration parameter to the same region as your bucket.

    select set_config_parameter('AWSRegion', '[your region]');

  • dbadmin=> select get_config_parameter('AWSRegion');

    get_config_parameter

    us-east-1
    select set_config_parameter('AWSRegion', 'us-east-2');

    set_config_parameter

    Parameter set successfully
    and bingo .... now it works !

    Thanks!

  • Hi Colin,
    Here is some good AWS documentation on the subject: http://docs.aws.amazon.com/AmazonS3/latest/dev/UsingBucket.html
    It looks as though you can add the region in the front-end of the URL notation.
    Dave

  • It seems to me that auto-created vertica database has AWSRegion parameter set to us-east-1 even though on the MC cluster creation page is set to us-east-2 . I can see this on a new cluster, so perhaps this needs to be correctly set during cluster provisioning.

  • +1, same for me. The V node is created in a US region.
    For me select set_config_parameter('AWSRegion', 'eu-west-1');
    solved this.
    Maybe the installation procedure can use the AWS region of the S3 bucket automatically?
    Dieter

  • Dieter, Colin, in addition to fixing the regional issues in a hot fix shortly after 9.0.1, the MC provisioning process will validate the region to avoid this incompatibility.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.