exporting a large table fails due to lack of space on the catalog volume on the target

I attempted to load a secondary 4 node cluster with the default storage configuration from a 3 node cluster in the default configuration.
The large fact table failed in the middle as the depot ran out of space.

vsql:export.sql:7: ERROR 2927: [verticadb] Could not write to [/vertica/data/VerticaDB/v_verticadb_node0003_data]: Volume [/vertica/data/VerticaDB/v_verticadb_node0003_data] has insufficient space.
vsql:export.sql:8: ERROR 2927: [verticadb] Could not write to [/vertica/data/VerticaDB/v_verticadb_node0003_data]: Volume [/vertica/data/VerticaDB/v_verticadb_node0003_data] has insufficient space.

Here is the vertica storage on the source on 1 node
/dev/md127 590G 356G 205G 64% /scratch_b
/dev/xvde 50G 1.3G 46G 3% /vertica/data

and on the destination
/dev/xvde 50G 260M 47G 1% /vertica/data -> filled up and then failed
/dev/md127 590G 142M 560G 1% /scratch_b

/vertica/data is the catalog path so why is that getting filled ? I checked and could not see files in either catalog / data , I suppose they are hidden or reference counts are held.

Anyhow, this should be workping a bit different and the depot should be used instead + S3 storage when the depot runs out.


  • Options
    skeswaniskeswani - Select Field - Employee

    The root cause may be that TEMP space is not the depot but rather the DATA location.
    in EON mode storage_location DEPOT, TEMP is the right home for TEMP , rather than DATA, TEMP.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file