The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

Not Enough Open File Handles Allowed

Comments

  • Vertica requires a large number of file handles. To avoid "too many files open" errors: Check the current limit: $ ulimit -n If necessary, permanently increase this limit for all users by editing the file /etc/security/limits.conf as root, and adding the lines: * soft NOFILE Soft limit is the default limit set when a user session starts and can be increased up to the the hard limit using ulimit . * hard NOFILE The hard limit is the absolute limit. where = 1 file per MB of RAM, or 65536, whichever is higher. Note: The leading asterisk means that the setting applies to all users. Set file-max to 1 file per 1 MB of RAM, or 65536, whichever is higher. This file defines a system-wide limit on the number of open files for all processes. If you see many error messages about running out of file handles, try increasing this value; for example: echo 100000 > /proc/sys/fs/file-max For further details, see the file-max section on the Linux man proc page. Log out and log in again. The new shell has the new ulimit setting. If you used sudo to install Vertica: View the /etc/security/limits.conf on each node in the cluster and verify that Vertica inserted the following lines at the end of the file: * soft NOFILE Soft limit is the default limit set when a user session starts and can be increased up to the the hard limit using ulimit . * hard NOFILE The hard limit is the absolute limit. where = 1 file per MB of RAM, or 65536, whichever is higher. Note : The leading asterisk means that the setting applies to all users. Log in as root and restart the system to ensure the settings are implemented: # etc/init.d/sshd restart If restart is not an option, stop and start sshd: # etc/init.d/sshd stop; etc/init.d/sshd start Verify the number of open files is 65536 (or 1024 on some operating systems): # ulimit -n 65536 Log in as the dbadmin user: # su dbadmin SSH from one node to another; for example, from host01: # ssh host2 Check the current file limit: # ulimit -n 65536 Notes: If the correct number of open files has not been established, reboot the host: # sync # reboot If the settings still do not take effect, enable UsePAM (set value to yes) in /etc/ssh/sshd_config and restart SSH once again. If the nofile parameter is less than 32768, Vertica fails and logs the following message: Not enough open file handles allowed (1024 available/32768 required); see 'ulimit -n'.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.