Network communication problem during Vertica installation

Hi, I am trying to install Vertica on a three node testcluster using the command /opt/vertica/sbin/install_vertica -s SE-VM-10-node1,SE-VM- 10-node2,SE-VM-10-node3 -r vertica-6.1.1-0.x86_64.RHEL5.rpm And do get this error Network Test (FAILED) ========================= Network communication (FAILED) ---------------------------------- Echo server failed on host 172.16.61.37:48073 : ['', ''] Echo server failed on host 172.16.61.37:48073 : ['', ''] Echo server failed on host 172.16.61.38:48073 : ['', ''] Echo server failed on host 172.16.61.39:48073 : ['', ''] Failed to send/recieve messages from all hosts, Check your netverify log for details and make sure your firewall and SELinux are disabled for the cluster interfaces. Can you please explain this and advise what I should do? Thank you Dieter

Comments

  • Hm... Well, I don't know offhand which the "Echo server" test is. But the implication is that it's trying to communicate on that network port and is unable to do so. The error text advises you to make sure your firewall is disabled. (Vertica's firewall requirements are detailed in the installation guide.) Have you disabled any/all firewalls on/between the machines in your cluster? If you are not sure, you should talk to whoever maintains your network infrastructure. The purpose of a firewall is to block network applications; if you do have a firewall, you'll have to configure it to let Vertica through. For simplicity, we recommend running without a firewall between nodes -- Vertica is a single network application; if you want to secure it, what you really want is a single firewall between your whole Vertica cluster and the rest of the world, rather than a bunch of firewalls between nodes. The text also advises you to make sure that SELinux is disabled. Have you done that? (SELinux is a Linux feature that ships with some Linux distributions, and is available for most as an add-on. If you're not familiar with it, look around online; a Google search for "disable selinux" turned up a bunch of results for me.) The text also recommends that you check the netverify log. Is there anything helpful there? If you have further questions about the instructions, feel free to ask. If you don't think either applies to you, it'd be great if you could provide more details.
  • Dieter_CapekDieter_Capek Registered User
    Adam, thank you for helping. My problem was that iptables was running. I was not aware that iptables is a Linux software firewall. Solution: service iptables stop chkconfig iptables off This solves the issus. Best regards Dieter

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file