Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

RESOURCE POOL Optimization

Working on Optimizing my Vertica cluster. After reading a few forums online, I decided to change a few setting in the general Resource Pool. So I ran the ALTER RESOURCE POOL line and my query slowed down dramatically. I then changed everything back to default settings but my query is still running really slow. It used to run in 45 Min and now take about 2 hours and 15 min. Is there any way to reset those settings?

Comments

  • You can see the defaults by querying table resource_pool_defaults. For example the defaults for general pool are : => select * from resource_pool_defaults where name ilike '%general%'; -[ RECORD 1 ]------------+------------------ pool_id | 45035996273718900 name | general memorysize | maxmemorysize | Special: 95% executionparallelism | AUTO priority | 0 runtimepriority | MEDIUM runtimeprioritythreshold | 2 queuetimeout | 300 runtimecap | plannedconcurrency | AUTO maxconcurrency | singleinitiator | f Please note that if you changed the maxmemorysize of the general pool, you will need to restart the database to take the new value. If you change this setting in other pools, restarting is not necessary. Hope this help. Eugenia
  • Thanks! That worked
  • jjjj

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.