Installing Vertica 6x on EC2 (both enterprise and CE) hangs on "Running Network Connectivity and Thr

Trying to install Vertica on aws/ec2, keep running into this problem: the installation script hangs at "Running Network Connectivity and Throughput Tests...", i.e. showing waiting 1/3 sites but never finishes. Control-C won't kill it unless "kill" from another session. Set up - varied. I tried all kinds: 1. 3 m2.2x large standard ec2 2. 3 m3.2x large vpc 3. 3 m2.2x large vpc 4. 3 cc1 vpc All CentOS rpm: vertica-ce-6.0.1-0.x86_64.RHEL5.rpm, and the 6.1.1 AMI image found on aws. Mostly installing as dbadmin with sudo enabled (e.g. dbadmin ALL=(ALL) NOPASSWD: ALL) Firewall/iptables turned on and off didn't make any difference. SELinux turned off too. The installation command line looks like: sudo /opt/vertica/sbin/install_vertica -s ip-10-0-0-99,ip-10-0-0-98,ip-10-0-0-100 (also tried with real IP) -r vertica-ce-6.0.1-0.x86_64.RHEL5.rpm -d /vertica/dbadmin/db -g vertica_admin -l /vertica/dbadmin -T (sometimes with -N and -C too) Still I am running into the same problem in every possible combination I can think of. What am I missing? Thanks, Bing


  • Options
    Hi Bing, thanks for your question. Just checking, which firewalls have you disabled? (Have you opened up communication using Amazon's tools?; they have their own limits in place independent of iptables.) Also, how long are you waiting for the command to complete? It can take several minutes if the network is configured properly; much longer in some cases if there are errors that cause connections to fail and time out. Assuming you are waiting for a while, it sounds to me like some firewall somewhere is still in place. Are you able to connect to those machines directly/manually on Vertica's documented ports, using a third-party program such as netcat? For example: On one machine: $ nc -l 5433 And on another: $ echo "testing" | nc [other-IP] 5433 This should cause the word "testing" to print in the first computer's terminal. Test this with all of the ports that Vertica needs, as documented at https://my.vertica.com/docs/CE/6.0.1/PDF/Installation%20Guide.pdf (page 24) (Note that the ports changed between 6.0 and 6.1; that document is for 6.0.) For UDP ports, use "nc -u" on both ends. My suspicion is that one or more of these commands will also hang.
  • Options
    Thanks for the instructions. Will try later. Bing

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file