The Vertica Forum is getting a makeover! The site will be undergoing maintenance from Tuesday 8/13 to Friday 8/16. We appreciate your patience and cooperation during this time.

Not able to create library function with R

Hi All, Trying to create a library function in R in version 6.1.1. Getting the dreaded “failed to get UDx side process info from zygote” error. Db logs read “cannot find system Renviron. Fatal error: unable to open the base package”. Referring to this documentation : https://my.vertica.com/docs/6.1.x/HTML/index.htm#17824.htm The docs don’t mention setting R_HOME anywhere. Have also tried setting R_HOME to /opt/vertica/R and /opt/vertica/R/lib to no avail. Any help would be appreciated. Thanks in Advance.

Comments

  • Hi Ravi, thanks for your question. I haven't worked extensively with Vertica/R, but I believe the Vertica 6.1 R RPM should no longer have the R_HOME issues that were present in the from-source build used with Vertica 6.0. That said, that documentation page lists some dependencies for the R package. Have you installed all of them? Do you have libgfortran.so in place on your system, per that page? Also, what Linux distribution are you using?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.