Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Microsoft SQL Server Analysis Services problems with floating point datatypes

I cannot add a Double measure in a cube, in MOLAP or ROLAP: every attempt to read a Money/Numeric/Float value from Vertica throws an ADO.NET exception: Errors in the high-level relational engine. The following exception occurred while the managed IDataReader interface was being used: Input string was not in a correct format.. Errors in the OLAP storage engine: An error occurred while processing the 'Fact Campaign Event Summary' partition of the 'Campaign Events' measure group for the 'CriteOlap' cube from the CriteOlap database. It may be an issue with the Vertica.xsl cartridge - that maps SSAS types to Vertica - you provide as part of the ADO.NET installer, I'll try to edit it and let you know. But if anyone has tested it... Please let me know.

Comments

  • i add the MOLAP Process XMLA response
  • The full MOLAP process sends this XMLA response Error ErrorCode="3239182362" Description="Errors in the high-level relational engine. The following exception occurred while the managed IDataReader interface was being used: Input string was not in a correct format.." Source="Microsoft SQL Server 2012 Analysis Services" HelpFile=""
  • I don't know if anyone from the product team reads this forum?
  • Hi Francois, we have employees from all across our organization keeping tabs on our community. I'll have someone from product and/or support take a look at those errors for you.
  • Thanks you very much Danielle, I'll wait for their answer. It's kind of important I make this work since we want to be able to validate this architecture as soon as possible..
  • If it can help I used your provider in a C# app, and I think you have a problem when parsing floats in a european environment (commas vs points), there must be a missing CultureInfo.InvariantCulture in the code.
  • Hi Danielle, did you succeed to get any feedback on this? Or have you an official channel to report bugs like this?
  • Hello Francois, Thank you for posting this issue to the forum. I have entered a defect in our database. Amy
  • Thanks Amy, I'll come back to see if there are any updates. Feel free to contact me if you need help for any kind of diagnosis.
  • They have a good understanding of the issue, but are interested in known how the locale is set when this problem occurs. Can you please let me know what the locale is when you hit the issue. Thanks
  • The Vertica locale is set to FR or US in the connection string, but SSAS seems not to care. The Windows locale was tested with values fr-fr and en-us (Control Panel and .NET CurrentThread.CurrentCulture), but it seems not to change anything. I've also tried to reinstall the ADO.NET drivers while having a US culture, still no luck. I've configured SSAS in fr and and en as well..
  • And what do they advise?
  • 27 days have passed and nobody has an idea about this?
  • This problem will be resolved in our next major release of the product, that is targeted to be released at the end of this year.
  • Hi, has the problem been resolved in 6.1.2?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.