The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

Failed when using none-root user with ssh-key auth install Vertica Cluster nodes

Failed when using none-root user with ssh-key auth install Vertica Cluster nodes There is a problem in Vertica Cluster installation using none-root user with sudo command. The test case is describing below: I try to install a 3 nodes Cluster on HPCS Node1: Public IP: 15.185.174.164 Private IP: 10.7.31.42 Node2: Public IP: 15.185.160.186 Private IP: 10.7.31.37 Node3: Public IP: 15.185.175.88 Private IP: 10.7.30.169 Using jbossadm user running sudo command, I successfully installed first and second nodes, but in the 3rd nodes installation I got the following errors, which indicate that in 3rd node the passwordless ssh connection not configured. Actually I did configured passwordless ssh connection both for root and jbossadm user(tested that I can login as root/jbossadm via ssh into other 2 nodes without password), and the second node was installed with same command without problem. Any one have experiences in using none-root user to install cluster Another question, after I success installed cluster, if I disable root login, is that Cluster could work properly. Thanks Rosso

Comments

  • continue... Error Msg mentioned above Waiting for 1 of 3 sites... ... Test of host 10.7.30.169 (FAILED) ===================================== Passwordless SSH access to other hosts (FAILED) --------------------------------------------------- Cannot connect from 10.7.30.169 to host 10.7.30.169 without password Vertica requires that SSH be configured for passwordless authentication. Verify that /etc/ssh/sshd_config is configured properly on 10.7.30.169. See the Vertica Installation Guide for more information. Test of host 10.7.31.42 (FAILED) ==================================== Passwordless SSH access to other hosts (FAILED) --------------------------------------------------- Cannot connect from 10.7.31.42 to host 10.7.30.169 without password Permission denied (publickey,gssapi-with-mic,password). Vertica requires that SSH be configured for passwordless authentication. Verify that /etc/ssh/sshd_config is configured properly on 10.7.30.169. See the Vertica Installation Guide for more information. Test of host 10.7.31.37 (FAILED) ==================================== Passwordless SSH access to other hosts (FAILED) --------------------------------------------------- Cannot connect from 10.7.31.37 to host 10.7.30.169 without password Vertica requires that SSH be configured for passwordless authentication. Verify that /etc/ssh/sshd_config is configured properly on 10.7.30.169. See the Vertica Installation Guide for more information.
  • Hm... Which user did you run the install command as? If If "jbossadm", does that user have both passwordless SSH *and* passwordless sudo on all three machines? The installer needs to be able to run as root; in the absence of a password, it may try to acquire root access via sudo. You could also look at the logs in /opt/vertica/log/ for more details about exactly what command is failing. Regarding root login, yes, you can disable root login after the cluster is installed.
  • Thank you Adam yes, it has both pwless ssh and sudo in all nodes, and I try to install it many times, some time it successfull installed, but most of time failed. let me try it and paste the error logs.
  • hi Adam is that possible that install vertica cluster don't need to provide user password (sudo user or root user) if I can setup key-pair auth for those users. Thanks Rosso
  • Hi Rosso, This may work if you run as root (not via sudo) and have passwordless ssh as root. But others on these forums have had trouble with that. The simplest way is with a root password. (I don't work on the installer myself; all I know is from reading the documentation, playing around with it, and looking at the installer script in /opt/vertica/.) Adam
  • the current solution is during installation I will enable root login, and disabled after. the key thing is when adding a new node into a existing cluster, root login should be re-enabled again for the node you want to run adding node cmd.
  • Hello! This is such a big issue, wish Vertica fixed this. Just tried a new install on a EC2 cluster with Vertica 7.0.1 and this is still an issue.
    This a big issue as requires a lot of manually messing with the cluster to make the install work. 
    Hope this will be fixed soon!




Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.