odbc problem

Hello, we’ve encountered following problem: after connecting to the VerticaDB via isql and performing SELECT, we get the following error: /usr/local/bin/isql -v VerticaDSN Username Password +---------------------------------------+ | Connected! | | | | sql-statement | | help [tablename] | | quit | | | +---------------------------------------+ SQL> select * from service_log; +--------+--------+| ID | TABLE HEAD | PORT |+-------+---------+ Bus error (core dumped) OS : HP-UX app06h B.11.23 U ia64 ODBC : 2.2.14 64bit - compiled DB: Centos 6.2 64bit + Vertica6.0.1 64bit odbc.ini: [VerticaDSN] Description=VERTDB Database Driver=/usr/local/OracleBI/odbc/lib64/libverticaodbc.so Database=DBVERT Servername=01vert UID= PWD= Port=5433 odbcinst.ini: [VerticaDSN] Description = VERTDB Database Driver = /usr/local/OracleBI/odbc/lib64/libverticaodbc.so [ODBC] Threading = 1 Do you have any idea what could be wrong? Thanks,


  • Hello Kristian, Please try to use UserName and Password instead of UID and PWD under file .odbc.ini Regards, Bhawana
  • I made the changes you suggested and still get the same error.
  • Hello Kristian, What version of ODBC driver are you running? Regards, Bhawana
  • Version of ODBC driver : 2.2.14 64bit
  • According to the Vertica documentation, HPUX 11.23 is unsupported platform for Vertica ODBC drivers. When running on HPUX 11iv3, the Vertica ODBC driver is working fine.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file