Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Upgrade to 6.1.2 fails

Hi, I am upgrading from 6.1.1 to 6.1.2 and get the failure below, thanks for helping. 192.168.31.18 /bin/bash 192.168.31.17 /bin/bash 192.168.31.16 /bin/bash 192.168.31.15 /bin/bash Installing rpm on 3 hosts.... installing node.... 192.168.31.18 Error: invalid literal for int() with base 10: '4%' Traceback (most recent call last): File "/opt/vertica/bin/verticaInstall.py", line 1232, in code, result = SSH.installNode( installerSSH, host, rootPassword, options.rpm_file_name, localhost, running_as ) File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/SSH.py", line 1986, in installNode if int(data[1][0]) < sz: ValueError: invalid literal for int() with base 10: '4%' Installation failed.

Comments

  • Sorry, just find the fix in the Problem area, it works now.
  • Luc,

    Glad that you have been able to fix the issue.

    This is a known bug that we have fixed in our next release. Can you tell us how didn you fix this? This will help the community.

    The workaroud we know is as follows:
    ===============================
    Edit /opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/SSH.py on node and goto line 1982. Change the command: 

    df /tmp | tail -1 | awk '{print $4}' 

    to 

    df -P /tmp | tail -1 | awk '{print $4}'  


    --
    Pravesh
  • Hi Pravesh, I applied the workaround that you describe, I found it in the problem area. Regarding the upgrade script, I also have one remark, it’s not really a bug, but I think it can be improved. The script asked many times for a password, without specifying the nature of this password (root, dbadmin, database ?). What was strange also is that at one point, I got the prompt below: Password:password:password: I blindly entered 3 times the dbadmin password, without being sure this was the correct answer…, and apparently it finally worked. That’s it. Regards, Luc

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.