Upgrade Vertica MC from Evaluate version to Enterprise edition

I downloaded the rpm for evaluation version of vertica console and now I have the enterprise edition license and want to upgrade from community edition to the enterprise edition. What are the steps to follow? I see that in the documentation it says that i need to download rpm and install which i already did using the evaluate version. Also i tried adding the license in the vertica console mc settings but it didnt change anything. can you please help. Thanks Saumya


  • wwong2wwong2 Employee
    Have you tried to upgrade / update your license through Admintools? see link for steps, https://my.vertica.com/docs/6.1.x/HTML/index.htm#15459.htm Regards
  • Yes Wayne, I tried that but the thing is when installing the mc i didnt install a database, mayb it automatically installs it i am not sure. But on trying to upgrade using admintool it is giving an error that it is not able to upgrade as its not able to connect to the database. Below is the message given " Failed to upgrade license key. Unable to connect to database. Unable to connect to any node in the database " [vert_admin@vrtalbult01 bin]$ ps -ef|grep verti 501 6256 1 0 Aug13 ? 00:07:24 /opt/vertica/vendor/oracle/java/jre/1.6/bin/java -Dvertica.home=/opt/vertica -Djava.library.path=/opt/vertica/lib -Dderby.system.home=/opt/vertica/mcdb/derby -Xmx2048m -Xms1024m -XX:MaxPermSize=256m -jar /opt/vertica/lib/webui.war 501 6276 1 0 Aug13 ? 00:24:13 /opt/vertica/bin/vertica -D /opt/vertica/mcdb/VERTICA/v_vertica_node0001_catalog -h -C VERTICA -p 5433 501 6283 6276 0 Aug13 ? 00:00:48 /opt/vertica/bin/vertica-udx-zygote 9 7 6276 debug-log-off /opt/vertica/mcdb/VERTICA/v_vertica_node0001_catalog/UDxLogs spread 8418 1 0 Jul15 ? 00:04:29 /opt/vertica/spread/sbin/spread -n N127000000001 -c /opt/vertica/config/vspread.conf 501 10614 10349 0 13:35 pts/1 00:00:00 grep verti [vert_admin@vrtalbult01 bin]$
  • wwong2wwong2 Employee
    Couple of things I would check 1) in admintools, Select View Database Cluster State and see if any of the individual nodes for the db are down. One of the nodes may be down. 2) Check the adminTools-dbadmin.log for more details. Logfile is located in /opt/vertica/log Regards
  • Wayne, 1) the database cluster state shows that it is up. This is a Management console installation hence its installed on only one node and that shows it to be up Here is the thing. So I installed mc and used the username vert_admin as the user. However when trying to connect to the db as vert_admin user it fails with password invalid. with dbadmin it connects to the db using vsql but when trying to connect using the admintools it gives the following error [dbadmin@vrtalbult01 bin]$ ./admintools Traceback (most recent call last): File "./admintools", line 196, in cmdController = commandLineCtrl.commandLineCtrl(makeUniquePorts, showNodes) File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/ui/commandLineCtrl.py", line 35, in __init__ self.__exec = adminExec.adminExec(makeUniquePorts, showNodes) File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/engine/adminExec.py", line 137, in __init__ c = Configurator.Instance() File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/config/Configurator.py", line 50, in Instance with FileLock( Configurator.CONFIG_FILE): File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/config/FileLocker.py", line 67, in __enter__ self.acquire() File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/config/FileLocker.py", line 40, in acquire self.fd = os.open(self.lockfile, os.O_CREAT|os.O_EXCL|os.O_RDWR) OSError: [Errno 13] Permission denied: '/opt/vertica/config/admintools.conf.lock'
  • wwong2wwong2 Employee
    Manually delete the admintools.conf.lock file and restart admintools.
  • if customer is using Vertica Community Edition and do we have separate Vertica MC Community Edition or some license for Vertica MC ?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file