The Vertica Forum recently got a makeover! Let us know what you think by filling out this short survey.

ODBC Driver Configuration Settings

I need to connect Vertica Database from the Dmexpress Server. For that I installed 32-bit Vertica-ODBC driver and set up the two files,odbc.ini and odbcinst.ini according to the instructions provided in Programmer's Guide. But this is not working though i followed all the steps. Can anyone suggest me how to deal with this problem?

Comments

  • New Additional Driver Information https://my.vertica.com/docs/6.1.x/HTML/index.htm#16836.htm
    The new HP Vertica version 5.1 ODBC driver has some additional configuration settings not covered by the standard ODBC.INI file. use a configuration file named vertica.ini on Linux, AIX, Solaris, and HP-UX. It controls several features of the ODBC driver.
    Location of the Additional Driver Settings https://my.vertica.com/docs/6.1.x/HTML/index.htm#17045.htm
    Creating a vertica.ini File There is no standard location for the vertica.ini file—you can store the file anywhere that it is convenient for you on your client system. One possible location is in the /etc directory if you have multiple users on your client system that need to access it, or have a vertica.ini file in each user's home directory so users can alter their own settings. Wherever you store it, be sure users have read access to the file. [...]
    also (on same doc page): https://my.vertica.com/docs/6.1.x/HTML/index.htm#17045.htm * Example vertica.ini File * Required Settings * Setting the VERTICAINI Environment Variable
  • Can you provide more information-what sort of error you get. Providing screenshot would be better.
  • I too created the file vertica.ini in /etc directory and configure accordingly. But still no improvement at all. The error goes like this: imageimage The scenario followed like this: SYNSCORT_HOME= /usr/local/dmexpress Path for odbc.ini and odbcinst.ini: $SYNSCORT_HOME/etc Sample of odbc.ini: [ODBC Data Sources] Vertica = "Verica database on HP Vertica" [Vertica] Description = Vertica Database Driver = HPVertica Database = Servername = UID = PWD = Port = 5433 ConnSettings = #SSLKeyFile = /home/dbadmin/client.key #SSLCertFile = /home/dbadmin/client.crt Locale = en_GB Sample of odbcinst.ini [HPVertica] Description = HP Vertica ODBC Driver Driver = /opt/vertica/lib/libverticaodbc.so Path of vertica.ini: /etc Sample of vertica.ini [Driver] DriverManagerEncoding=UTF-16 ODBCInstLib=/usr/lib/libodbcinst.so ErrorMessagesPath=/opt/vertica/lib LogLevel=4 LogPath=/tmp I also added the path of vertica.ini in /etc/profile by adding export VERTICAINI=~/.vertica.ini
  • Hi! Are you joking? Ok, all definition/configurations are done for user "dmexpress", SO WHY YOU ARE WORKING AS ROOT? Did you configured ODBC for root?
  • I had the same issue and when I use 64bit drivers isql works.
  • I have done the same configuration, I am getting "unicode converter overflow" issue while connecting in cognos. It the same configuration is fine in unix server (isql).
  • Hi,
    I am using HP Vertica 7.0.1 Virtual Machines on windows 7 laptop.now i need to connect the Vertica(VMart database). i already installed the vertica 64 bit client in my laptop. could you help me out how do i connect/ odbc configuration in windows laptop.

    Regards
    Mahesh

  • Hi Mahesh,

    Did you get to connect/odbc configuration in windows laptop?

    thanks,


  • no,i didn't get it..

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.