Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

unixODBC and vertica 6.1.3

I installed Vertica 6.1.3 CE, the unixODBC package (I'm running RHEL 6.3).
I also downloaded the Linux ODBC drivers from here (https://my.vertica.com/download-community-edition/, under "Individual drivers") and extracted them to /usr/lib64 so that libverticaodbc.so is available there. I did an ldconfig.

Although I can connect with VSQL to a newly created database, I can't succeed in connecting to my Vertica Database : "Could'nt SQLConnect"

I tried using a vertica.ini in /etc, with not more success.

What drivers shall I use ? Am i supposed to use the Vertica 5.1 unixODBC drivers ???

Thank you !

Comments

  • I also add that I have an odbc.ini and odbcinst.ini in /etc having their Driver directive pointing to /usr/lib64/libverticaodbc.so

  • Additionnaly, I have odbc.ini and odbcinst.ini pointing to the so file as uncompressed from the linux drivers archive.
    I also tried a /etc/vertica.ini file with not more success.

  • Looks like the vertica.ini is now mandatory when using the new non-unixODBC-only ODBC drivers.
    Nut sure why this file is needed when odbc.ini could do the job but well... Cut-n-pasting the sample in the documentation did the trick.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.