Community Editon Virtual Appliance License expired end of november 2013

The community edition virtual appliance license expired over the weekend:


(1 row)

I don't know where to get a new license from. Attempting to "Advanced Tools" -> "Upgrade License Key" with no path incorrectly reports Error 4943: The Enterprise Edition is installed. You cannot downgrade from the Enterprise Edition to the Community Edition.

This is with the virtual appliance downloaded and installed on the 29th of November, which was working then, and is now broken.


  • Options
    Hi Alan,

    Curious, what version of Vertica is this?  ("select version();")

    I see the following when I run that command on my own CE installation:

    => select display_license();
     Vertica Community Edition
    1TB CE Nodes 3
    (1 row)

    I'll double-check about our appliance -- it should have the newer license as well.  (The 500mb license is very old, and was only available for a short time when we first released the CE.)

    In the worst case, you could just download the latest .rpm package and install it in the appliance.  Certainly not an ideal solution; but if you want something to try yourself while we're investigating, it's an option.

  • Options
    I had downloaded vertica-vmsmsrvr-6.1.3-0.64.zip from https://my.vertica.com/download-community-edition/ (so I assume it is a proper community edition).

    It does claim to be v6.1.3 as well:
    dbadmin=> select version();
     Vertica Analytic Database v6.1.3-0
    (1 row)

    I downloaded and installed vertica-6.1.3-0.x86_64.RHEL5.rpm. I had to --force it as:

    $ sudo rpm -i vertica-6.1.3-0.x86_64.RHEL5.rpm
            package vertica-6.1.3-0.x86_64 is already installed

    After installing the above rpm I ran
    $ sudo /opt/vertica/sbin/install_vertica

    But still in the same state as before, with same select_version() and license()

  • Options
    There are no license file?
  • Options
    There is one, but I'd guess vertica isn't using it. Not sure if I missed a documented step, but it does not tie up with display_license().

    [dbadmin@vertica ~]$ ls /opt/vertica/config/licensing/ -l
    total 4
    -rw-rw-rw- 1 root root 586 Sep 27 01:00 vertica_community_edition.license.key
    [dbadmin@vertica ~]$ md5sum /opt/vertica/config/licensing/vertica_community_edition.license.key
    7c90d7600b90af4dab77496be567f2c7  /opt/vertica/config/licensing/vertica_community_edition.license.key
    [dbadmin@vertica ~]$ cat /opt/vertica/config/licensing/vertica_community_edition.license.key
    Vertica Community Edition
    1TB CE Nodes 3

  • Options
    >> There is one, but I'd guess vertica isn't using it
    So what you are waiting for? Install it!
  • Options
    I can't... is there a workaround - I'm have no data or anything I need to keep so just nuking and starting from scratch is fine if there is a process that works. I don't seem to get to choose a license on database create.

    Failed to upgrade license key.
    ERROR 4943:  The Enterprise Edition is installed. You cannot downgrade
    from the Enterprise Edition to the Community Edition   

  • Options
    OK sorted now:
    rpm -e vertica
    rm -rf /opt/vertica #This is needed
    rpm -i vertica...rpm

    And then on first run it asks for a license file and you just press enter. This didn't happen first time after running up the appliance.

    Thanks for the help
  • Options
    Last VMs has problems.

    Install Vertica manually - it's not so hard, read documentation and follow to guidelines or wait (good luck with this) for work around.

    IMHO - official VMs are very bad: bad for development, bad for testing and of cause bad for production. They are good for demonstration only. (Im repeat: its IMHO)
  • Options
    I'm using the VM as a "vertica" black box to test against - for non-performance related testing. I don't want to pollute my existing OSes with something I'm going to use rarely. The vendor supplied VM should be easier for me to just download and run, but in this case it didn't work out that way. Installing a suitable OS then vertica on top should have taken longer.
  • Options
    so wait... of cause it's better, you don't need to do nothing
    (installation will take 3-4 hours, even less :-), you already have VM + OS, just reinstall Vertica... or wait.. for a couple days for solution)

    [ -L { license_file | CE } ]

    Silently and automatically deploys the license key to /opt/vertica/config/share. On multi-node installations, the –L option also applies the license to all nodes declared in the –s host_list.

    If specified with CE, automatically deploys the Community Edition license key, which is included in your download. You do not need to specify a license file.

    Good Luck!
  • Options
    Hey now -- Alan is right; this is clearly a bug on our part.  We do always recommend running real/production installations on real hardware.  But VM's are useful too; and because they're often used for demonstration purposes, they should work well out of the box.

    You seem to have collectively hit upon the right approach to the workaround -- use "install_vertica" to install the appropriate license.

    Anything involving user databases being down is a big deal to us.  We're currently building a VM image that doesn't have this issue.  It sounds like you're set for now?  If others need more-detailed (or simpler) instructions on how to fix existing VM's, post here and we'll get something to you.

    Daniel:  If you want to help us get workarounds out faster, come do it yourself.  No really; we're hiring :-)  We do care, and we work hard to respond quickly; but we're small and Vertica is becoming a big thing, so we realize that we need to expand to keep pace.
  • Options
    I recently hit this problem as well... ideally, I'd like to keep using my 6.1.1-0 Virtual Appliance for testing since that's the same version we're using in production.
    Would it be possible for you to post a license file and instructions for installing it?

  • Options
    Hi Emanuel,

    We released an updated/fixed 6.1.3 CE VM; you're welcome to use that version.  Unfortunately, 6.1.1 is somewhat old at this point; we only release Community updates to the latest version...  (Older versions have bugs that are fixed by newer patches, etc.  If you're running 6.1.1 in production, it might be worth thinking about patching.)

    Also unfortunately, fixing this is not as simple as you'd like -- the license that got shipped with that VM image has some funny properties, including ones that make it difficult to install a different Community license in its place.  Though there are instructions elsewhere in this thread that may or may not work for you.

    If you need 6.1.1 for compatibility with your production deployment, and if your production deployment has an Enterprise Edition license, that's something you could raise a Support case about (at my.vertica.com).  They have much more flexibility regarding supporting older versions and dealing with licensing issues; they can probably give you a better answer.

  • Options

    Can anyone tell me what was the impact of vertica license expiry on cluster

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file