Can't change Restart Policy on Vertica 6.1.3 / CentOS 6.5

After installing Community Edition of Vertica (see version in subject) on
my CentOS installation, I can't set the Restart Policy for the db I created as it returns the error:

Unable to restart policy until cluster is fully reachable.
The following communication failed: from

It is a single-node cluster with disabled iptables .

SSH passwordless has been already set for dbadmin user.

How can I proceed ?

Thank you



  • Options

    According to documentation:
    Setting the Restart Policy

    The Restart Policy enables you to determine whether or not nodes in a K-Safe database are automatically restarted when they are rebooted. Since this feature does not automatically restart nodes if the entire database is DOWN, it is not useful for databases that are not K-Safe.

    Single node cluster are not K-Safe.
  • Options
    Hi Daniel,
    thank you for your reply.

    Anyhow, my primary need is having the database started whenever I restart the server.

    I thought that was a solution.
    Which settings should I change to make it start whenever the server i rebooted ?

    The VM I downloaded from the Vertica site had that setting already set (and databases
    are re-started whenver I restart the Virtual Machine).

    Thank you for your support
  • Options

    I think that is done via inid system, may be in /etc/rc.local

    Anyway, you can set it by yourself: add to /etc/rc.local
    /opt/vertica/bin/vertica -C <database> -D <catalog> -h -p 5433
  • Options
    This will do what you need :

    /opt/vertica/bin/admintools -t set_restart_policy -d <database> -p 'always'

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file