Vertica 7: script install_vertica prints wrong reports/status.
daniel@synapse ~ $ sudo /opt/vertica/sbin/install_vertica --hosts --dba-user daniel --dba-group daniel --data-dir /vertica --dba-user-password-disabled --clean --license CE --accept-eula
[sudo] password for daniel:
Vertica Analytic Database 7.0.0-0 Installation Tool

... long output omitted
>> Validating node and cluster prerequisites...

Failures during local (OS) configuration for verify-
HINT (S0305): https://my.vertica.com/docs/7.0.x/HTML/index.htm#cshid=S0305
TZ is unset for daniel. Consider updating .profile or .bashrc

but TZ is defined !
daniel@synapse ~ $ tail -3 ~/.bashrc 

export PATH=$PATH:/opt/vertica/bin
export TZ='Asia/Jerusalem'

(Debian 6 is not supported? O_o)
    HALT (S0322): https://my.vertica.com/docs/7.0.x/HTML/index.htm#cshid=S0322
Debian-based OS version 'wheezy/sid' is not supported.
HP Vertica Server and HP Vertica Management Console
Supported Operating Systems

HP Vertica7.0.x runs on the following 64-bit operating systems on x86_x64 architecture:

  • Red Hat Enterprise Linux 5 and 6
  • SUSE Linux Enterprise Server 11
  • Oracle Enterprise Linux 6 - Red Hat Compatible Kernel only - HP Vertica does not support the unbreakable kernel (kernels with a uel suffix)
  • Debian Linux 6
  • Cent OS 5 and 6
  • Ubuntu 12.04LTS
@ Andrew: "O Brother, Where Art Thou?"


  • Options
    Hi Daniel,

    For "TZ", what happens if you run "echo $TZ" as the user 'daniel'?

    For Debian, "wheezy" means Debian 7; "sid" means Debian Unstable.  Regular Debian 7 is an interesting question (since it's been fully released for a little while now but hasn't yet made our "Supported" list), but we definitely don't support Debian Unstable.  Try again with Debian 6; I just successfully installed there.

  • Options

    Thanks for replay.

    Just for fun - I installed it even on Arch Linux :-), just report about something...(annoying?) wrong. Because when you trying to build an OEM package, you don't wanna see any warning messages.
    daniel@synapse ~ $ echo $TZ               

    About stable/unstable: i think it was some random error...O_o (may be something in environment, but message uninformative and wrong) because, on third or forth try it installed without this warning.
  • Options
    I will continue here. Ok?
    Something goes wrong when dbauser and group are not default.

    1. Fail
    daniel@synapse ~ $ /opt/vertica/bin/adminTools 
    Warning : Can't write to '/opt/vertica/log/adminTools-daniel.log'
    IOError : [Errno 13] Permission denied: '/opt/vertica/log/adminTools-daniel.log'
    Message was: [adminExec.__init__] Unique Ports: False
    Warning : Can't write to '/opt/vertica/log/adminTools-daniel.log'
    IOError : [Errno 13] Permission denied: '/opt/vertica/log/adminTools-daniel.log'
    Message was: [isOkToRun] owner of admintools.conf (dbauser) is root.
    User daniel is not allowed to run adminTools. To enable access run install_vertica
    2. Fail
    daniel@synapse ~ $ sudo chown -R daniel:daniel /opt/vertica/config/
    daniel@synapse ~ $ /opt/vertica/bin/adminTools
    Warning : Can't write to '/opt/vertica/log/adminTools-daniel.log'
    IOError : [Errno 13] Permission denied: '/opt/vertica/log/adminTools-daniel.log'
    long output
    error message: [Errno 13] Permission denied: '/opt/vertica/log/uiMgr-daniel.log'
    trace file: /opt/vertica/log/adminTools-daniel.errors

    3. Success
    daniel@synapse ~ $ sudo chown -R daniel:daniel /opt/vertica/log/
    daniel@synapse ~ $ /opt/vertica/bin/adminTools
    But... I was asked to enter a path to license and EULA, while I defined it in command line.

  • Options
    a next one:
    adminTools failed to create an interface object.
    Please resize your window to a larger width and height
    ??? http://www.youtube.com/watch?v=ho3jD6aiZ8E

  • Options
    Ok, I found a root of evil, it's option:
    it doesn't work properly, script creates all objects as root, and not as dba-user.
  • Options
    Thanks for the detailed reports; keep 'em coming! We of course never intend to have any bugs. But it's a new installer; it fixed a lot of existing issues but it looks like it created some new ones. Let us know; we'll get them fixed.
  • Options
    Hi Adam!

    When dba-user is not a default value (dbadmin) and user already exists, so Vertica scratch installation goes wrong(It doesn't set all permissions for example).
    I can't point more on errors (EULA, RevEna) and  I don't think that this is a right place.

    This error(Vertica 7: 'NoneType' object is not subscriptable on create database) have same roots.

    >> keep 'em coming!
    Try my best to improve Vertica.
  • Options

    Try changing the value in file /etc/redhat-release (or similar file in Ubuntu). Make it anything less than 7 (5.6) and it should not throw that error. This is the workaround that I have used several times while installing Vertica on Ubuntu/Deb for testing.
  • Options
    @Siddarth Kotnala
    Thanks, for help, but I solved id :-)

    I solved all my problems, im just reports about wrong default behavior, about something that doesn't work out of box. So far I have no open problems/questions :)
  • Options
    ok :-)
  • Options
    Hi Daniel,

    The permission denied errors that you see indicate that the installation did not complete.  Note that an unsuccessful install ends with: "AdminTools and your existing Vertica databases may be unavailable. Investigate the above warnings/errors and re-run installation."

    You may have resolved this issue manually, but others may be lurking.  You should re-run the installer to completion, after resolving or acknowledging the incompatibilities and warnings which it provided.

    Regarding TZ not being set: This environment variable needs to be set for non-interactive
    shells.  .bashrc  may be quitting early in the case of non-interactive shells. I believe that Ubuntu has this behavior, which causes the confusion:
    # If not running interactively, don't do anything
    [ -z "$PS1" ] && return

    Best of luck,

  • Options
    Hi Derrick!

    Thanks for replay, you are right about interactive and non-interactive shells.
    I just followed to the reference :
    To set the TZ variable, edit, /etc/profile, or /dbadmin/.bashrc or /home/dbadmin/.bash_profile and add the following line (for example, for the US Eastern Time Zone):
    export TZ="America/New_York"

    setting TZ to root helps, but Ubuntu has no root account, but Vertica supports now Ubuntu

    Sorry for late replay, somehow I missed it. Sorry but installation package has a lot of "misses". Good sysadim/integrator can cope/over(right word?) on all or most of problems but common user not. Main problem of Debian-like package - its alien. Hm... and I was really surprised.  Enterprise package? For me: Debian-like package are non-tested, so RH/SLES/CentOS are supported platforms by Vertica and only.
  • Options
    Main problem of Debian-like package - its alien.
    Thanks for the feedback.  If there are any specific problems with an alien-created package that we are not addressing, we will investigate.  At this time, our testing (on all platforms) shows a reasonable level of compatibility with well-configured (or default configured) systems.

    Glad you resolved the problem.
  • Options

    So sorry, Im blind :(

    No, problem not in alien it self (now it works good enough) a problem on my opinion you do not tests it. "I will try it on my notebook" - its not a test. You do not know how many times I got a "fake" error because of "Echo server: stty -echo"(or something like this) especially on Debian(it require a small modification in netverify.py and it works perfectly)

    A lot of medium/small customers uses in different hosting services, and hosting always do a small modification in system configurations(no binary), especially in network. So enterprise package require a wide and heavy tests.

    Its only my personal opinion.
  • Options
    Can I help to improve installation process?
    (mail: setarckos at gmail.com)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file