Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

New session rejected because of 50 session limit

When trying to talk to Vertica, we get rejected with the following error.

Severity: FATAL, Message: New session rejected due to limit, already 50 sessions active, Sqlstate: 57V03, Routine: addClientSession, File: /scratch_a/release/vbuild/vertica/Session/SessionManager.cpp, Line: 544
 
I'm not aware of where the 50 session limit is set. When I look at the number of active sessions, it is well below below 50. Is there a way I can raise the limit on the cluster? Or is it baked in?

Comments

  • There is a general parameter MaxClientSessions that controls the max number of client sessions for a single node. The default is 50. It can be changed via a select such as the following:
    SELECT SET_CONFIG_PARAMETER ('MaxClientSessions', 100);

    More info can be found in the Admin Guide under the "General Parameters"
    and "Managing Sessions" pages.

  • Thanks! That does it for us. 

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.