"failed to create database VMart" using VMware-CE v.


Following the Getting Started Guide PDF, and using the VMware-CE edition , when I run the install_example, the return message is that it Failed to create the database: 

$ cd /opt/vertica/examples
$ /opt/vertica/sbin/install_examples VMart
Installing VMart example database
Thu Feb 13 20:32:26 EST
Creating Database
Failed to create database VMart

1) services:  
      a) vertica_agent is running
      b) verticad -- 'Vertica: No Spread installed"   
2) The file VMmart_Schema folder does exist:   /opt/vertica/examples/VMart_Schema
3) Version Downloaded: VM (vmdk) of the CE edition (vertica-vmsrvr-7.0.0-0.64.zip)
4) Running the commands from a terminal in linux with user: dbadmin.

I have not yet installed the management console.  Is there something missing that needs to be done?  What is a spread, and does it need to be installed?



  • Hi Andrew,

    You do not need Management Console installed. Did it provide any more detail when the database creation failed?  Do you have a VMart directory in /home/dbadmin?

    edit to add: Spread is installed automatically as part of Vertica. It is used for cluster communication when you have multiple nodes installed.

  • Hi Chris,

    Thanks for getting back.  No, /home/dbadmin/ only has the DataCollector folder and the Desktop.
    I retried the install_examples and there is no more detail than what I listed above.

    Is there a problem with the VM image?  
    I'm just getting started, so I was hoping not to have to read all the manuals just yet to get.  Other than the getting started pdf.

    Any suggestions are appreciated.
    Thanks, Andrew 

  • OK,  I think i have this resolved.  partly due to user newbie, partly due to the Getting Started Guide missing some 'minor' details.

    OK, for the  Community Edition,in the Running Administration Tools section, it states that the CE edition users do not need to complete this section.  Oh, this is so wrong, at least the the VMware  I downloaded.  Users DO need to first run the administration tools, and select the CE edition to get Vertica formally setup (licensed).  I would suggest that you do one of the following:  update the Getting Started manual, or update the CE VM so that this step is already done.  Once I did this, the install_example VMart command is now working.

    I'd suggest that you update the manual.  

  • Hi Andrew,

    Thanks for letting us know!  I will open a defect against the manual and we will get it updated.


  • Thanks again for all the support.   'defect' is such a strong word.  Otherwise the manuals so far are good.    I've setup an ODBC from a Win7 machine and connected Access. Works well.  Now we'll see about connecting dBeaver.
  • Hi ,
    I am also having similar problem , while creating VMart DB I am getting similar issue . How to solved this . I have installed community edition vertica- and while creating example DB I got same issue as above.

    please share a link from where we can get test DB for vertica as similar AdventureWorks DB for MSSQL which works both in express and Enterprise edition.
    Also, cannot we have vertica test DB or example schema along with data which works for both community and enterprise edition.

    looking for some help.
    Anil Maharjan
    BI Engineer

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file