Social Media Connector Error - SSL problem

I'm using Vertica 7.0, and installed the social media connector successfully following the steps from Github tutorial. When I start the TwitterAgent, I get the following error message:

403:The request is understood, but it has been refused. An accompanying error message will explain why. This code is used when requests are being denied due to update limits ( - SSL is required
code - 92

I searched on the web and read that twitter requires SSL connections from the aplications, but I don't know where to change this settings, I couldn't find anything in the conf file.

Could anyone help?


  • Hmm, that is odd. I have it running now and I did not need to change any SSL settings.

    Try editing: SocialMediaConnector-master/dist/apache-flume-1.3.1-bin/flume-ng-agent and adding the following property to the last line:
  • Chris, it worked! Thank you very much!
  • It looks like twitter started requiring SSL in Feb 2014. I wonder if any applications created after that date require SSL be on, but applications created before that date do not need to turn on SSL.

    Thanks for bringing this up. I will add a note about it on the github social media connector page.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file