backup errors

Trying to run backup for the first time and getting:

13733: vbr server subproc on terminates with returncode 126. Details in vbr_v_verticadb_node0002_server.log on that host.

Error msg: bash: /tmp/vbr/vbr.py: /opt/vertica/oss/python/bin/python: bad interpreter: Permission denied

Does anyone have any ideas to fix this?



  • Options
    Prasanta_PalPrasanta_Pal - Select Field - Employee
    What shell and what version of OS you are using? /tmp folder should have proper access
  • Options
    The shell is Bash (is that right? not a Linux person) OS is redhat 6.4.  I am checking /tmp folder and the permissions are set to 1777.  I am working with a tech and so far we change the permissions on the bin folder which gave us another error "

    Error msg: rsync: failed to connect to IP address of backup host: No route to host (113)

    rsync error: error in socket IO (code 10) at clientserver.c(122) [sender=3.0.7]

    rsync failed!"

  • Options
    Prasanta_PalPrasanta_Pal - Select Field - Employee
    It looks like bash but can be checked as below:
    $ echo $SHELL

    check /etc/hosts file on all the nodes , there should be an entry of the backup host in all the nodes.

    Or alternatively, you may ping to the backup hosts or try connecting through ssh
    A per requirement of backup, the backup host should be accessible through paswordless SSH

  • Options

    I worked with the Vertica tech and finally got it to work.

    1. make sure password SSH is working on all nodes

    2. make sure permissions are correct on all folders

    This was my problem....3. make sure the SELinux and IPTable are set correctly. 

    Once I conferred with our Linux guy he looked at #3 and made changes.

    Now it works.

    Thanks everyone!!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file