The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.
Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Troubleshooting interrupted data re-balance

I was running a data re-balance on a Vertica cluster using Admin Tools. Mid-operation, my SSH session was disconnected. I re-connected to the cluster and tried to run the re-balance operation again.

When I do that I see this:
    ERROR: Unable to generate re-balance script.
    Workspace rebalance_data already exists
I'm guessing that's because the first re-balance I kicked off is still running or didn't clean up properly.

How can I get past this?

Comments

  • Hello Nicholas,

    To remove all previously run (and hung) processes, you can do this from the vsql prompt:

    SELECT dbd_drop_all_workspaces();

    Once complete, please reattempt to run the rebalance script.

    Thanks,
    Rory
  • Alright, that worked. Thank you.
  • You're welcome!
  • Thank you Nicholas for the post! But why is this   dbd_drop_all_workspaces not documented in the official docs. 
    Thx
  • Hello Adrian,

    A bug ticket is currently open to have this command added to our documentation. Hopefully it will be added in the near future.

    Thanks,
    Rory
  • Great !
    Already wrote it down :)
  • Great idea! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file