epoch table

i inserted couple of rows to the table. 
I queried select epoch, * from table.
I got two rows with epoch numbers.
I did not see one of the epoch numbers in epoch table when I did select * from epoch
I am keeping history. I have done this
SELECT SET_CONFIG_PARAMETER('HistoryRetentionTime', '-1');
SELECT SET_CONFIG_PARAMETER('HistoryRetentionEpochs', '-1');
Won't epoch table keep all epochs?
why it doesn't keep some epochs?


  • Options
    I'm assuming  you issued a commit after the first insert. Epochs don't get assigned until the commit occurs.

    Setting both to -1 disables both. 

    You need to set a time (in seconds) to the first, or a number representing retained epochs to the second.

  • Options
    It is an auto commit environment. I was able to see epoch in the source table for two rows but one of the epochs was missing in epoch table.
    I set both history params to -1 to keep history for ever. Is this a way to keep history for ever? not for certain time period or for certain number of epochs...
  • Options

    Setting both to -1 will disable both. Not sure there is a way to enable it forever, but if there were, it might as well be called the "crash your database" parameter. Your better option is to model the tables in a way to accommodate this. Retaining that many delete vectors (from deletes and updates) means that the database can't manage the files internally as efficiently as it needs to. Those delete vectors will need to be moved around and updated internally (instead of removed) and eventually the amount of housekeeping Vertica will need to do internally won't be able to keep up.

  • Options
    Ok. Thanks.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file