vertica-7.0.1 installation error


I am new to HP vertica. Currently trying to setup the community edition vertica-7.0.1-0.x86_64.RHEL5.rpm on a centos 6.5 release of 3 nodes.  Unfortunately the installation has failed with the following error! 

Can someone help me quickly to solve this problem ?  

Thanks in  advance, 

>> Starting installation tasks.
>> Getting system information for cluster (this may take a while)...

Default shell on nodes: /bin/bash /bin/bash /bin/bash

>> Validating software versions (rpm or deb)...

>> Beginning new cluster creation...

backing up admintools.conf on

>> Installing software (rpm or deb)...

Installing rpm on 2 hosts....
installing node....
Error: __exit__
Traceback (most recent call last):
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 1065, in run_install
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 745, in _main
    install_error = SSH.installNode( installerSSH, host, options.rpm_file_name, running_as )
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/SSH.py", line 1704, in installNode
    [ nodeHost ], DBinclude.rpmDestFile)
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/adapterpool.py", line 283, in copyLocalFileToHosts
    with apool.setHosts(dest_hosts):
AttributeError: __exit__
Installation FAILED with errors.

AdminTools and your existing Vertica databases may be unavailable.
Investigate the above warnings/errors and re-run installation.



  • Options
    Abhishek_RanaAbhishek_Rana Vertica Employee Employee

    Can you please verify that , you are able to do password less  ssh from all 3 nodes to one another from root user. It seems you have issues with password less ssh for root user on all 3 nodes.

    Once passwordless ssh is configured, try again to do the installation.


  • Options
    Thanks a lot :-) . It worked after correcting the ssh passwordless configuration.

    Can you please  let me know how can I change the dbadmin MC ( Management console)  password? 

    I am able to ssh with dbadmin but the same password not works on the MC. 


  • Options

    The MC password is defined when you setup the MC for the first time.
    I would suggest removing the MC and reinstalling it so that you are able to st the password again.
    Do let me know if you have already worked it out and how.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file