New install of MC on seperate server not working

Hello, new to vertica. I have installed the 7.0 MC on a newly setup Linux 6 VM and it will not bring the web ui up to complete configuration. I am not sure what to check. Any ideas?
I have a 3 node cluster that is already setup and running which I can administer using admintools but cannot access it from MC.


  • It depends where your install is failing, I had a security issue with the certificate in IE so I gave Chrome a go and eventually got it to load up, then the MC was able to complete its installation.
  • This was an install to a linux server that was just built. It does not have any of the other vertica software on it. I could not tell from any of the documentation if the other software was required. The only directory created was /opt/vconsole. I can do a console stop and start command and the output of the commands seem to indicate the MC is stopped/started as expected.
    I'll keep looking for the answers.
  •  Do you receive any errors ? How so you access the webui ? Provide more info ! show the console log ! 
    We need some help in order to help :) !
  • As far as I can tell I received no errors and I'll paste in the info requested.
    1.Console log

    2.Web URL
    response is "Internet Explorer cannot display the webpage"

    3.Ping server and Stop console command;image

    4.Start console command;

    Let me know if you need more.
  • I am using IE 9 and I have also tried firefox 30. These browsers have worked with another MC I have installed on my community edition(completely different server). Please note, there are NO other vertica installs on this server, no community edition etc. The mcdb file under /opt/vconsole/mcdb is empty also.

    Port info:
  • wwong2wwong2 Employee
    Have you checked the ports?

    from earlier link,

    Port Requirements

    Port 5444 is the default agent port and must be available for MC-to-node and node-to-node communications.

    Port 5450 is the default MC port and must be available for node-to-MC communications.

    1) check to see if port 5444 is open.

    At browser, type in IP address of one nodes using port 5444 ie https://mynode:5444 It should display version information.
    Please verify for all nodes

    2) is agent running?
    issue command ps -ef | grep vertica

    3) any details in the mconsole.log located in directory, /opt/vconsole/log/mc
  • The server I installed MC on ( does not have any vertica processes except MC running. Port 5450 on that server is listening and grep shows console running. I checked one of the nodes ( using a browser and port 5444 and it returned version info for 7.0.0. I also checked for the agent on the server and it shows agent is running.

    Since I did the install for MC on its own separate server( I have not been able to get a web page to display to complete setup.
  • This is the console log which I did not send yesterday.
  • wwong2wwong2 Employee
    Thanks for checking the ports.  Can you zip up / email me the complete mconsole.log for review?
  • I was thinking of doing an install of the vertica software on this standalone host as currently it only has the console package installed. What do you think?
  • I did the install and it did not work. Back to square one.
  • Hy Casey ! I have posted a video with an uninstall and a full install of MC and also stop start routine ! - is not edited and has no sound but i hope it will help you get around ! 
    Follow link - 
    - i will try to make a better edit next time :) kkk 
  • I did the uninstall and full install and had the same output as you did. When I tried to connect using firefox I did not get the security exception and the browser screen will not display. It is such a simple install and I do not understand why the browser will not display. I have not completed the video yet as I am still looking into what may be keeping the browser from showing. I have also asked for some internal assistance but have not been able to get it as yet.
  • Adrian, I finally found the problem. The IPTABLES were causing the problem. I must have missed that part of the documentation.
    The page is now displaying and I can complete setup of the MC.
  •  That is great ! :) Happy that you resolved your issue. 
    Same old pre-reqs :) kkkkk

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file