The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

VSQL in Unix- Locale Issue

Hi,
I am trying to connect to HP Vertica DB from AIX unix box, I am getting error message as follows 
"Invalid locale: run the "locale" command and check for warnings". When I issues the locale command I could see that locale is set to en_US.UTF-8

$ locale
LANG=en_US.UTF-8
LC_COLLATE="C"
LC_CTYPE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=en_US.UTF-8

Can anyone help and advice whats wrong or do I need to do any other settings?


Comments

  • Hi,

    Kindly modify the locale settings so that all locale paramters should have "en_US.UTF-8" and not "C".

    Thanks,
    Shobhit
  • Hi Shobit,

    LC_ALL is currently set to en_US.UTF-8. LC_ALL overrides all LC_* environment variables with the given value.

    Please Advice.
  • Did you able to connect from diffrent server ?
  • I am able to connect from my Windows machine. Did not tried on other AIX server, the idea is to connect first from Development server and then move to Production.
  • I am also facing similar issue.. any pointers on resolution is really helpful.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.