Installing management console 7.0 on Virtual machine

Management console on VM

 I tried installing MC for ubuntu using   $ sudo dpkg -i vertica-console_7.0.1-0_amd64.deb

 Error: Sudo:dpkg: command not found

Instructions from

http://my.vertica.com/docs/7.1.x/HTML/index.htm#Authoring/InstallationGuide/InstallingMC/InstallingManagementConsole.htm?Highlight=installing management console


  • Options
    Hi kasi, Could you please verify that you are running on Ubuntu (not RHEL/Fedora/etc)? Also that you have typed the command correctly? Does the "yum" command exist on your system? "dpkg" is a built-in package management tool on all Debian and Ubuntu systems. If it's missing, then either what you have isn't actually Ubuntu, or the system has been either secured or corrupted in some way that disables or restricts package installation. If you're not able to figure this out, let us know; others here may be able to help. (The first thing I would check would be sudo's PATH.) You would probably have better luck over on the Ubuntu forums, though, since dpkg is a core Ubuntu command. Adam
  • Options
    Adam, Thank you for responding.

    I have ubuntu installed from Vertica downloads. yum works however dpkg doesn't. I will look for it in ubuntu fourms.
  • Options
    Hi kasi, I'm curious, what version of Ubuntu do you have installed? If you run "cat /etc/lsb-release", it should tell you. Thanks, Adam
  • Options
    Sorry, I've CentOS release 5.5

    I got it from my.vertica.com - VMWare Server 2.0 and workstation 7.0(vmdk).

    Management console is available for the following, i've selected ubuntu. What do you recommend?

    Red Hat Enterprise Linux 5 and 6, 64 -bit

    SUSE Enterprise Linux server 11, 64 -bit

    Debian Linux 6, 64-bit

    Ubuntu 12.04 LTS, 64-Bit

  • Options
    Ah, I see -- CentOS is a variant of Red Hat Enterprise Linux.  (It's basically RHEL without a support contract.  Red Hat provides extensive technical support, which many enterprise users like, but you have to pay for it.)

    So I would recommend downloading the Red Hat Enterprise Linux RPM and following the corresponding installation instructions.

    I don't remember for sure, but you might want to double-check whether the Management Console is already installed on the VMWare image on our website.  You can see all installed Vertica packages by running something like "rpm -qa | grep vertica".
  • Options
    Thank you Adam. I didn't find MC on VM, so tried to install Red Hat Enterprise Linux 5 and 6, 64 -bit. It threw an error saying can't create transaction lock in /var/lib/rpm/__db.000

  • Options
    Hm...  Are you sure you're installing as root?  (Via sudo or su, etc -- I believe our docs mention that this is necessary?)

    If that's not the problem, try plugging "can't create transaction lock in /var/lib/rpm/__db.000" into your favorite search engine.  I get a bunch of results when I search for that error message.
  • Options
    You sir are a genuis..I used sudo and it worked. I really appreciate all your assistance with this.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file