How can I use plyr and reshape2 R packages with Vertica?

I am trying to create an R UDF which relies on the plyr and reshape2 R packages.  Before installing these packages, my other R UDFs worked fine.  However, after running install.packages("plyr") in the R terminal, none of my R UDFs work anymore.

It seems that Rcpp is related to the problem since the dbLog contained the following two lines:
Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[]) : 

  namespace ‘Rcpp’ 0.10.2 is already loaded, but >= 0.11.0 is required

/opt/vertica/bin/vertica-udx-R: error while loading shared libraries: libRcpp.so: cannot open shared object file: No such file or directory

Is there any way I can use plyr and reshape2 with Vertica 7.0.x?  It worked in an older version of Vertica...


  • Options
    Hi Rebecca, It sounds like you are trying use a version of plyr (or reshape2) that is too new for that version of Vertica. You could try installing an older version of plyr; perhaps the same version as you used with the previous version of Vertica. Alternatively, if you are an Enterprise user, you could upgrade to the newly-released Vertica 7.1. This version bundles Rcpp 0.11 so should work with the version of plyr that you are installing now. (Unfortunately, the Community release with Rcpp 0.11 has been delayed, but it's coming.) Adam
  • Options

    1. You are prompted to update each package that has an update available for it. Do NOT update:
    • Rcpp
    • Rinside

      You can optionally update any other packages installed with the R Language Pack. You must update any packages that you manually installed and are not compatible with R 3.0.

      The packages you selected to be updated are installed. Quit R with the command: quit()

  • Options
    Using the older versions of plyr and reshape2 worked like a charm - thanks!!
  • Options
    Thanks for your comment.  I followed these instructions, but installing the newest version of plyr automatically installs Rcpp.
  • Options

    I already have Vertica 7.1 installed on the cluster, but I still can't use the latest reshape library. The RCPP library is still version 0.10.2 instead of 0.11.

    Did I missed something?
  • Options
    PRanaPRana Employee
    Hi Said,

    You are correct in noting that the Rcpp version is still 0.10.2 in Vertica 7.1. We are working towards the upgrade but ran into some roadblocks. We expect to come out with the updated version in the near future.

  • Options

    Rebecca, which versions of plyr and reshape2 have you installed?


    Thank you

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file