Problem configuring cluster


I installed Vertica and now I want to create a cluster with 3 nodes.
The command I type to create the cluster is:

/opt/Vertica/sbin/install_vertica --hosts,, --rpm vertica.rpm --dba-user dbadmin

The message that appears is that the hosts 203 and 204 were Successful, but there is a problem with the host 205, the message that appears is this:

/opt/vertica/oss/python/bin/python: No module named vertica

Can you help me?



  • Options
    wwong2wwong2 Employee
    Make sure root and dbadmin ids can passwordless ssh to that node
  • Options
    Hi Wayne Wong,

    Both root and dbadmin are unable to passwordless ssh.
    The configuration is the same for all 3 nodes.

    Any other ideas?


  • Options
    On node 205 you could check for the rpm -

    rpm -qa | grep vertica

    ... and if it is there, then check for the following -

    ls -l /opt/vertica/oss/python/lib/python2.7/site-packages


    lrwxrwxrwx 1 root root     31 2011-10-26 10:19 vertica -> /opt/vertica/share/eggs/vertica
  • Options
    I am running into a similar problem, when I run ls -l /opt/vertica/oss/python/lib/python2.7/site-packages  -

    lrwxrwxrwx 1 root root     31 2011-10-26 10:19 vertica -> /opt/vertica/share/eggs/vertica does not exist.

  • Options
    Also,  root and dbadmin are able to passwordless SSH.
  • Options
    If you can, try installing the rpm on the problem node and running the install from there.
  • Options
    I'll give that a try.  I also ran ln -s /opt/vertica/share/eggs/vertica /opt/vertica/oss/python/lib/python2.7/site-packages and now I run into this:

  • Options

    I have solved this problem, following the next steps:


    At different nodes that doesn't work, you should go to 




    and create this links, if they doesn't exist:


    ln -s /opt/vertica/share/eggs/vertica   /opt/vertica/oss/python/lib/python2.7/site-packages/vertica


    ln -s /opt/vertica/share/eggs/py /opt/vertica/oss/python/lib/python2.7/site-packages/py


    ln -s /opt/vertica/share/eggs/ipaddress.pyc   /opt/vertica/oss/python/lib/python2.7/site-packages/ipaddress.pyc


    ln -s /opt/vertica/share/eggs/ipaddress.py   /opt/vertica/oss/python/lib/python2.7/site-packages/ipaddress.py


    ln -s /opt/vertica/share/eggs/flufl   /opt/vertica/oss/python/lib/python2.7/site-packages/flufl


    For me, this solution have solved my problem, and I could finish the installation without problems.


    I hope this can help you.


    Centos7 + vertica






Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file