Getting error [Vertica][VJDBC](2052) ERROR: COPY: Row size nnnnnnnn is too large for bulk load


I am new to vertica. We have 1 node test instance and are trying to load data using the bulk loader and getting the error :-

[Vertica][VJDBC](2052) ERROR: COPY: Row size 1701409377 is too large.

I have defined the base table and one projection.

We are using version 7.0.2. I have googled and searched this user community but no luck.

Any help/pointers would be great.



  • Options
    wwong2wwong2 Employee
    Hi, wonder if this problem occurs outside of JDBC?  Does issue occur when run direct via vsql?
    Also, is there a column that is defined too small for the values that is being loaded?
  • Options
    Hi Wayne,

    After working through some things here's how we resolved the issue. I am documenting it for future reference if other folks face the same issue. Some of it comes down to being a newbie.

    1) SELECT SET_CONFIG_PARAMETER ('StandardConformingStrings' ,'0');
    2) Restart Vetica instance so setting takes effect.
    3) We were extracting data to a flat file, comma separated. We used double quotes for the quoted strings - this NEEDS to be \" (backslash,double quote)

    ref - https://my.vertica.com/docs/4.1/HTML/Master/14677.htm

    The bulk loader seemed to work OK once we made these changes.

    Hopefully this will save some frustration for others.

  • Options
    Nimmi_guptaNimmi_gupta - Select Field - Employee
    Thanks for providing the solution and glad to hear it's working now. Just curious what was the default value for StandardConformingStrings before setting to '0'. 
  • Options
    Hi Nimmi,

    The value for the  StandardConformingStrings before we reset it was -1. This seems to be the default.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file