Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

What is ERROR 5238: Unrecognized node type?

What does "ERROR 5238: Unrecognized node type" (followed by a 3 digit code) mean?

A query that appears well formed fails with this error on Vertica 7.0.x, but Class 52 does not appear in the 7.0.x Documentation's SQL State List.

The meaning of node type is clear enough, but under what circumstances would a node type not be recognized?  Is this most likely a bug, a problem with the cluster, a SQL problem, or something else?

Comments

  • This might just be from trying to use a column that DNE.
  • Indeed, looks like this error resulted from a syntax error in the SQL.  Still not sure what the error code exactly means--that would still be great to find out.
  • What syntax was used that caused this?
  • A window range definition 'interval '5' preceding' was ''5'::interval PRECEDING'.  Any word on what the error means?
  • I'm having the same issue. The query works when I use interval '7' preceding but when I put that in a view Vertica changes it to interval '7'::interval preceding and that doesn't work with the same error. Any idea? I also tried interval '7 DAYS' preceding but when creating the view it changes to '7'::interval
  • I also tried interval '7 DAYS' preceding
    try:
    INTERVAL '7 day' DAY
    or full format
    INTERVAL '7d 0h 0m 0s'
    Only 2 interval data type exists: year to month & day to seconds, all others are their subtypes. So a second example isn't require a qualifer, for example you can cast it:
    daniel=> select interval '7d 0h 0m 0s' hour ;
    ?column?
    ----------
    168
    (1 row)

    http://my.vertica.com/docs/7.1.x/HTML/index.htm#Authoring/SQLReferenceManual/DataTypes/Date-Time/Spe...
  • we found out this is a bug and the fix will be included in 7.1SP2. The # is VER-36682

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.