Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Vertica 7.1 VM : Not being able to use MC or trying to take back up

Hi,

I installed vertica 7.1.1 virtual machine on my VMWare. The installation apparently working fine. I can follow the basic examples like creating a database (VMart), getting some data from it etc. But to experiment with MC, I installed the same vertica-console-7.1.1.0]

[[email protected] Desktop]$ rpm -qa | grep vertica
vertica-7.1.1-0
vertica-console-7.1.1-0

Now, when I am trying to access the console with the port it specified:
https://vertica:5450/webui
I get a time out error. The Firewall is disabled in the VM. So I can not access MC.

Now coming to problem 2, when I try to do the back up example, the back up fails as it can not connect to host.


[[email protected] Desktop]$ vbr.py --task backup --config-file exampleBackup.iniPreparing...
Found Database port:  5433
ssh: connect to host 192.168.1.1 port 22: Connection timed out
Unable to ssh to host: 192.168.1.1
backup failed!

Firewall is anyway not running, I checked /etc/init.d/sshd service is running. I tried vsql -l followed by echo $?, the result looks good [Refered to https://community.vertica.com/vertica/topics/how_to_tell_if_vertica_is_ready_to_accept_connections] Entries in

/etc/hosts file looks legitimate.
127.0.0.1               localhost.localdomain localhost::1             localhost6.localdomain6 localhost6
192.168.1.1             vertica

I tried to go refer https://community.vertica.com/vertica/topics/unable-to-create-first-database-in-vertica-on-centos , but not sure if I have same problem here.

Can anyone please let me know what is the issue I have here. Am I missing anything very basic?

Note: I work behind proxy, is that has anything to do?
Thanks.


Comments

  • Can you include the output to the following -

    cat /opt/vertica/config/admintools.conf
    ifconfig -a
    cat exampleBackup.ini
    ping 192.168.1.1 (from the browser workstation)

    You may have used the localhost IP.
  • Hi Raul, thanks for looking into this. Please find the details below.
    Is it because "hosts" is pointing to localhost? The vbr.py is trying to access 192.168.1.1 whereas here it is defined as 127.0.0.1.

    Just for your information, I am just using a single Vertca virtual machine on my laptop. I do not have multiple nodes etc.

     ----------------------
    [[email protected] Desktop]$ cat /opt/vertica/config/admintools.conf

    [Configuration]
    install_opts = 
    default_base = /home/dbadmin
    show_hostnames = False
    format = 3
    last_port = 5433
    controlmode = broadcast
    spreadlog = False
    controlsubnet = default
    largecluster = 1
    tmp_dir = /tmp

    [Cluster]
    hosts = 127.0.0.1
    spread_hosts = 

    [Nodes]
    node0001 = 127.0.0.1,/home/dbadmin,/home/dbadmin
    v_vmart_node0001 = 127.0.0.1,/home/dbadmin,/home/dbadmin

    [Database:VMart]
    restartpolicy = ksafe
    port = 5433
    path = /home/dbadmin/VMart/v_vmart_node0001_catalog
    nodes = v_vmart_node0001

     ----------------------
    Result of /sbin/ifconfig -a     

    eth0      Link encap:Ethernet  HWaddr 00:xx:yy:zz:11:1x            inet addr:15.80.xxx.yyy  Bcast:15.80.xxx.yyy  Mask:255.255.254.0
              inet6 addr: abcd::efg:xxxx:feeb:xyza/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:18414 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3058 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:4900650 (4.6 MiB)  TX bytes:751090 (733.4 KiB)

    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2443 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2443 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:2493697 (2.3 MiB)  TX bytes:2493697 (2.3 MiB)

    sit0      Link encap:IPv6-in-IPv4  
              NOARP  MTU:1480  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

     ----------------------
    ping 192.168.1.1

    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
    --- 192.168.1.1 ping statistics ---
    5 packets transmitted, 0 received, 100% packet loss, time 4002ms
  • Please read
    [[email protected] Desktop]$ cat /opt/vertica/config/admintools.conf
    [Configuration]
    .
    .

    as

     
    [[email protected] Desktop]$ cat /opt/vertica/config/admintools.conf

    [Configuration]
    .
    .


    I tried to edit it but somehow the edit is not working. Apologies.
  • For the MC issue, try pointing the browser to the IP of the host directly instead of the "vertica" alias in your /etc/hosts, so -
    https://15.80.xxx.yyy:5450/webui
    And for the backup, change the entry in the exampleBackup.ini file to point to 127.0.0.1
     
  • Awesome!.. Thanks... Couple of points I additionally needed to do are
    1. In exampleBackup.ini I need to give complete path for the password file. Though I was running the vbr.py from the directory where the password file is located it was complaining it is not finding it.
    2. The firefox version came with CentOS Vertica VM is outdated and MC is thus not working properly. I tried to upgrade, that seems not working. Anyway, I used my windows box/chrome to communicate to the address:port, works fine.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.