Node migration from Vertica 5 to 7



I'm here again with another problem related to installation proccess. So we have old cluster with vertica 5 and we are trying to migrate to vertica 7. So we excluded one node from old cluster, removed Vertica 5 (apt-get purge package_name) from it and installed Vertica 7. After that we tried to install this node into new cluster with command /opt/vertica/sbin/update_vertica --add-hosts new_node -r /home/user/vertica_7.1.1-0_amd64.deb  -L /home/dbadmin/license.dat


And during its execution we have received this


>> Completing installation...

Running upgrade logic
Spread upgrade required. Some nodes have a shared/legacy vspread.conf
Warning: Not all hosts have a shared vspread.conf. Found on:
Fetching shared vspread.conf from
Error: failed to get network profiles
Could not find a suitable network interface:
Upgrading database 'stats3' ...
(For databases with large catalogs, this may take some time.)
Error: string indices must be integers, not str
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 1097, in run_install
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 970, in _main
if not run_upgrades(running_as, options.vertica_dba_user, executor):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 86, in run_upgrades
return IntegrateSpread.upgrade_integrate_spread(running_as,user,executor)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/upgrade/IntegrateSpread.py", line 208, in upgrade_integrate_spread
if not upgrade_db(pool, db, nodes, clustersettings, profiles, aexec, spreadInfo['port'], userName):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/upgrade/IntegrateSpread.py", line 268, in upgrade_db
'controlAddress': profiles[host][0],
TypeError: string indices must be integers, not str
Installation FAILED with errors.

AdminTools and your existing Vertica databases may be unavailable.
Investigate the above warnings/errors and re-run installation.
**** - master node - new node


So that was the moment when I was scared but cluster seems to be ok, up and running. But little investigation found following things: vertica 7 found old spread config in /opt/vertica/config/vspread.conf (no idea why it was not removed during vertica 5 uninstallation) and this config was copied to master node in the same location. All other nodes have spread config only in /home/dbadmin/stats3/v_stats3_node000<node_num>_catalog/spread.conf.


We fixed problem with network on master node that was mentioned in this message and tried to start installation process again as it was adviced. But we got message that node was already added into cluster.


So what we should do now? Is it safe to remove old spread config from this location?



  • Options
    SruthiASruthiA Vertica Employee Administrator



      Can you share me the contents of adminTools-root.log




  • Options

    Is there anything specific that I should look for? it is pretty big even for one day and I'm afraid that there could be some sensitive data.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file