The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

vsql: unsupported locale character encoding use a utf8 locale, not a ISO8859-1 locale

when I use the vsql command, I encountered following Error

 

$./vsql
vsql: unsupported locale character encoding
  use a utf8 locale, not a ISO8859-1 locale

 

Then I did try changing the locale settings as follows...

 

$export LANG=en_US.UTF-8

 

But now encounterign a different error :-(

 

$./vsql      
Invalid locale: run the "locale" command and check for warnings
$

 

And when I check my local settings.. I see it as following

 

$locale
LANG=en_US.UTF-8
LC_COLLATE="C"
LC_CTYPE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=en_US.UTF-8
$

 

Any suggestions to resolve the same is really helpful.

 

thanks,

Subbarao

Comments

  • SruthiASruthiA Employee

    Hi,

     

       Did you set the locale at the session level? If so, when you start new session, it will have the old setting. Please set locale either in .profile or .bashrc for dbadmin user. 

     

     

     

    -Regards,

     Sruthi

  • I export those parameters from profile and tried to login as below, i got same error.

     

    mechine:vertica/opt/vertica/bin$./vsql -U abc_user -w ******* -h ABC-vegat-xyz.com
    Invalid locale: run the "locale" command and check for warnings
    mechine:vertica/opt/vertica/bin$

     

     

    Thanks,

    Subbarao M P

  • SruthiASruthiA Employee

    Hi,

     

     

        From the error message, it seems to be locale is invalid. You can try the following to ensure locale is set correctly.

     

    1) Set the locale in .profile or .bashrc

    2) Exit the session

    3) Login into new session and run locale to see what it gives (This confirms whether locale has been set globally or session level).

    4) try using vsql

     

    -Regards,

     Sruthi

  • I am getting this error: I am running Informatica and for that I have to set the env variable LANG (export LANG=C) but vertica doesn't like it. When I set (export LANG=en_US.UTF-8) Informatica crashes after a while. Please share if there is a way to keep Vertica and Informatica happy with one setting.

    vsql: unsupported locale character encoding
    use a utf8 locale, not a 646 locale

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.