Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Invalid integer format '0.0' for column

Hi,

 

I am using vertica database as my repository for saving the Pentaho ETL transformations and Jobs. When trying to save Pentaho ETL, i am getting an error saying -

"Unable to save step info to the repository for id_transformation=1

Error inserting/updating row
[Vertica][VJDBC](100172) One or more rows were rejected by the server."

 

Then i queried vertica error message table to see the error message(select * from error_message). In the vertica db side i could see the error message as follows:

 

2015-10-27 05:45:25.73565-04 | v_newrepository_node0001 | 45035996273704962 | dbadmin | localhost.localdoma-2989:0x297e | 0 | 4503599627
3711819 | 423 | ERROR | 67788930 | Invalid integer format '0.0' for column 6 (VALUE_NUM).

 

Can anyone tell me how to fix this issue?

Comments

  • It might be that your data type is an int and your are feeding a numeric value, try changing the data type of the column to numeric.

  • Hi

     

    I changed the column to interger and tried to save the transformation. Still the same error

     

    And i was having the column as float as well, still the same error.

     

     

  • Also i found that i was using wrong version of vertica JDBC jar. After i changed the jar file to the correct version, the issue is fixed and I am able to save the pentaho transformations to the vertica db repository.

  •  that is interesting to see that the error treatment is totally crazy :) it points you to a totaly different path :) 

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.