Vertica Driver - Database Ports Above 32767 Not Supported

KurtKKurtK Registered User

I'm using Vertica in a Docker image with Docker Compose. When doing this it exposes Vertica to the host machine on a Random port. However, it appears that the Vertica driver is unable to connect to Vertica if it's on a port above 32767. When a port such as 32768 is supplied it will revert it to 5433 before connecting which fails as Vertica is not listening on that port.

 

Is there a reason that this is not supported? Can the driver be updated to support this?

Comments

  • NorbertKNorbertK Registered User

    My guess is because it's above the maximum value that 2 bytes (signed) can store.

  • KurtKKurtK Registered User
    That's my guess as well. Docker assigns a dynamically exposed port in the ephemeral port range which is going to be frequently above 2-byte limit so it would be really great if the driver could be updated to use a data type with a higher limit to accommodate these port values which in my opinion should be valid.
  • NorbertKNorbertK Registered User

    Interestingly, the 6.0 documentation shows that higher ports (48073 and higher) must be open. I believe UDP/TCP still use up to 65535. Which specific driver are you using?

  • KurtKKurtK Registered User
    I'm using the Vertica JDBC driver. I believe I tried both 6 and the latest 7 driver release but I can get you the specific version numbers tomorrow morning.
  • KurtKKurtK Registered User

    I'm trying to connect to Vertica using the latest JDBC driver: vertica-jdbc-7.2.0-0.jar

     

    It's still not allowing me to connect via a port number that greater than 32767. When port numbers greater than this are supplied it just tried to connect on 5433.

  • KurtKKurtK Registered User

    Ping...Can anyone help address this issue?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file