The Vertica Forum recently got a makeover! Let us know what you think by filling out this short, anonymous survey.

Unable start DB after upgrade 7.0 to 7.2

we upgraded the the DB from 7.0 to 7.2 directly .Upgrade completed successfully .But not able to start the database using admintools .

[email protected]:/apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog> /opt/vertica/bin/admintools --tool start_db -d PHIDB -p BDVh3STe
Unable to read database catalogs - cannot start database.
Database PHIDB did not start successfully
[email protected]:/apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog> cd /home/
[email protected]:/home> pwd
/home
[email protected]:/home> echo -e "listdetails Site" |/opt/vertica/bin/vertica -D /apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog/ -E'batch'
/opt/vertica/bin/vertica: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/vertica/bin/vertica)

Please advise is this problem with direct upgrade from 7.0 to 7.2 ? is there is any solution on this?

Thanks
Renjith Alex

Comments

  •  I think you are missing gcc ! 

    Also the upgrade path clearly states that is from 7.0 --> 7.1 --> 7.2 , you might of missed some libs in the process.

     

    Install gcc, this will also install the libstdc++.so.6.

     

    After this try to start the database.

     Also make sure all path variables are avaialbe and set.

  • Yea .Yor are correct . issue has been solved after installing it .

     

     

  •  

    Great to hear that your issue was solved. 

     

    Please mark the reply with the fix for your issue, others might use it. - I guess this is the purpouse of the forum.

    "knowledge exchange"

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.