how to monitor a backup process

i ran a backup process that is been running for 4 hours on a 400 GB database , the command i used was   

nohup /opt/vertica/bin/vbr.py --task backup --config-file /home/dbadmin/Backup_Full20162502.ini

 

am connected to the server through putty , 

i lost my connection an hour after the backup was running but logged in again and i can see the process when running ps - eah 

now i dont see it running anymore , and when i run a query to database_snapshots the query doesnt finish it just hang there . 

 

how can i make sure that the backup is running and whats the approximate time for it to finish ?

Comments

  • Hi ,

    Looks like you have some kind of global catalog lock , check your locks table to verify  what is being locked , you may also see some useful info with regard to your backup process .

     

    You can also query your sessions table , to see if your backup is still active 

     

    Thanks

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.