Vertica backup error- Error: Unable to connect to backup host via password-less SSH: 127.0.0.1

Hari_raoHari_rao Registered User

Hi, I'm trying to take backup of the databases in a server. The first time when I created the config files for the backup and ran, there was no problem in the backup process. Now after changing the ssh port from default to other port, I try creating the config file with advanced settings and proving the port for ssh and rsync, I'm getting this error when I'm trying to initialize the config file.

 

Error: Unable to connect to backup host via password-less SSH: hostname.
Init FAILED.

 

The backup is being taken in the same server and vertica is setup with one node and only one cluster.

Could anybody help me on this?

Comments

  • Rahul_ChoudharyRahul_Choudhary Registered User

    Hi Hari

     

    Can you kindly let us know the database version on which you are running this backup? 

     

    Also provide us the backup (vbr.py) log to look into it.

     

    Thanks

    Rahul

  • Hari_raoHari_rao Registered User

    Hi Rahul,

     

    We are using Vertica-7.2.3 database. Where is the backup log saved?

  • Hari_raoHari_rao Registered User

    Hi Rahul,

     

    I have attached the latest log file herewith.

  • Hari_raoHari_rao Registered User

    Could this be a bug in the vbr.py script because by default it takes only 22 port for rsync and ssh. I have given the parameter port_ssh_backup = port_num in the config files for the database but it doen not take this port number at all.

  • wlodi83wlodi83 Registered User
    edited May 2017

    I have exactly the same problem. I am using Vertica Analytic Database v8.1.0-2. I defined in backup.ini file following option:

    [Transmission]
    port_ssh_backup = 222

    Do you know how to solve the issue? I was able to change that in vbr.py file but I don't want to do it anymore. I would like to use options.

  • AB71AB71 Registered User

    @wlodi83 : "I was able to change that in vbr.py file but I don't want to do it anymore." By doing that, were you able to take the backup? I have the same problem, and looking for ways to solve it. Shall post when I crack the issue.

  • jheffnerjheffner Employee, Registered User

    When running sshd on a non-standard port, I'd recommend creating entries in your admin user's ssh client config. For instance, in ~/.ssh/config, add
    Host 127.0.0.1
    Port 222

  • ashu123ashu123 Registered User

    I have the same problem :'(
    Error: Unable to connect to backup host via password-less SSH: 127.0.0.1.
    Init FAILED.

    [[email protected] ~]$ /opt/vertica/bin/vbr --setupconfig
    Warning: This setup tool is deprecated, and will be removed in a future version. Please use config file samples we provide in /opt/vertica/share/vbr/example_configs instead of using this tool.
    Snapshot name (backup_snapshot): fullbak
    Number of restore points (1): 1
    Specify objects (no default): 
    Object restore mode (coexist, createOrReplace or create) (createOrReplace): createOrReplace
    Vertica user name (user_testing): 
    Save password to avoid runtime prompt? (n) [y/n]: 
    Node v_db_testing_0_node0001
    Backup host name (no default): 127.0.0.1
    Backup directory (no default): /home/user_testing/backup
    Change advanced settings? (n) [y/n]: n
    Config file name (fullbak.ini): /opt/vertica/config/vbr.ini
    Saved vbr config to /opt/vertica/config/vbr.ini.
    

    I'm attaching vbr.ini file

    cat /opt/vertica/config/vbr.ini
    [Misc]
    snapshotName = fullbak
    restorePointLimit = 1
    objectRestoreMode = createOrReplace
    
    [Database]
    dbName = db_testing_0
    dbUser = user_testing
    dbPromptForPassword = True
    
    [Transmission]
    port_ssh_backup = 5055
    [Mapping]
    v_db_testing_0_node0001 = 127.0.0.1:/home/user_testing/backup
    

    Plz provide solution

  • ashu123ashu123 Registered User

    this is my hosts file /etc/hosts
    [[email protected] ~]$ cat /etc/hosts
    127.0.0.0 localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

    I'm using Vertica Analytic Database v8.1.1-0 version on a single node.what I have to do?

  • jheffnerjheffner Employee, Registered User

    Did you give the suggestion above a try: setting up a host/port config in ~/.ssh/config?

    Also, for node-local backups I'd suggestion using the empty host notation to specify the backup location, for example, v_db_testing_0_node0001 = []:/home/user_testing/backup

  • ashu123ashu123 Registered User
    edited February 1

    hello @jheffner this is my admintools.conf

    [[email protected] ~]$ cat /opt/vertica/config/admintools.conf
    [Configuration]
    last_port = 5433
    tmp_dir = /tmp
    default_base = /home/dbadmin
    format = 3
    install_opts = --failure-threshold FAIL --dba-user user_testing --hosts '103.18. ** . ** ' --rpm 'vertica-8.1.1-0.x86_64.RHEL6.rpm'
    spreadlog = False
    atdebug = False
    controlsubnet = default
    ipv6 = False
    controlmode = broadcast
    unreachable_host_caching = True
    admintools_config_version = 103

    [Cluster]
    hosts = 103.18. ** . **

    [Nodes]
    node0001 = 103.18. ** . ** /home/user_testing,/home/user_testing
    v_db_testing_0_node0001 = 103.18. ** . ** ,/home/user_testing/catalog,/home/user_testing/data

    [SSHConfig]
    ssh_user =
    ssh_ident =
    ssh_options = -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2 -o StrictHostKeyChecking=no -o BatchMode=yes

    [Database:db_testing_0]
    restartpolicy = ksafe
    port = 5433
    path = /home/user_testing/catalog/db_testing_0
    nodes = v_db_testing_0_node0001
    is_eon_mode = False
    depot_base_dir
    depot_size
    communal_storage_url
    num_shards

    So what I have to do at v_db_testing_0_node0001 = []:/home/user_testing/backup

  • ashu123ashu123 Registered User

    hello @jheffner
    yes I did, this is my .ssh/config
    [[email protected] ~]$ cat .ssh/config
    Host 127.0.0.0
    Port 5055
    This is my admintools.config
    [[email protected] ~]$ cat /opt/vertica/config/admintools.conf
    [Configuration]
    last_port = 5433
    tmp_dir = /tmp
    default_base = /home/dbadmin
    format = 3
    install_opts = --failure-threshold FAIL --dba-user user_testing --hosts '103.18. ** . ** ' --rpm 'vertica-8.1.1-0.x86_64.RHEL6.rpm'
    spreadlog = False
    atdebug = False
    controlsubnet = default
    ipv6 = False
    controlmode = broadcast
    unreachable_host_caching = True
    admintools_config_version = 103

    [Cluster]
    hosts = 103.18. ** . **

    [Nodes]
    node0001 = 103.18. ** . ** ,/home/user_testing,/home/user_testing
    v_db_testing_0_node0001 = 103.18. ** . ** ,/home/user_testing/catalog,/home/user_testing/data

    [SSHConfig]
    ssh_user =
    ssh_ident =
    ssh_options = -oConnectTimeout=30 -o TCPKeepAlive=no -o ServerAliveInterval=15 -o ServerAliveCountMax=2 -o StrictHostKeyChecking=no -o BatchMode=yes

    [Database:db_testing_0]
    restartpolicy = ksafe
    port = 5433
    path = /home/user_testing/catalog/db_testing_0
    nodes = v_db_testing_0_node0001
    is_eon_mode = False
    depot_base_dir
    depot_size
    communal_storage_url
    num_shards
    Am i doing anything wrong ??

  • Jim_KnicelyJim_Knicely Administrator, Moderator, Employee, Registered User, VerticaExpert

    In your /etc/hosts file, why are you using the IP 127.0.0.0 for you local host as opposed to 127.0.0.1?

    127.0.0.1 is a loopback address while 127.0.0.0 is a network address.

    Anyway, shouldn't your .ssh/config file be this?

    Host 127.0.0.1
    Port 5055

    You have this:

    Host 127.0.0.0
    Port 5055

  • jheffnerjheffner Employee, Registered User

    You'll probably need to create an entry for your node's IP address because it's not running on localhost -- you've got it obscured as "103.18. ** . **".

  • ashu123ashu123 Registered User

    This is current permission to vertica db, Is this ok or I need to change it ??
    drwxrwxrwx 9 user_testing verticadba
    Please provide a solution to backup my db,I'm stuck :(

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file