Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Unknown error while running Database Designer.

Vertica 7.1 Community Edition

 

Ran database designer, comprehensive option.  I did not submit any additional custom queries.

 

How might I fix the following error?

 

I do not have Enterprise edition so cannot submit support ticket to HP.

 

---

Database Designer started.

For large databases a design session could take a long time; allow it to complete uninterrupted.
Use Ctrl+C if you must cancel the session.

Setting up design session...

Examining table data...
No existing projections found.


Creating design and deploying projections...

Unknown error while running Database Designer.
Design process may still be executing in the background.



Designer did not run successfully
Unknown error while running Database Designer.
Design process may still be executing in the background.

Press <Enter> to return to the Administration Tools menu.

---

Comments

  • For me the same issue with Vertica 8.0 on Community Edition.

    This happens even when running the VMart example initial "Comprehensive Design" stage from here: https://my.vertica.com/docs/8.0.x/HTML/index.htm#Authoring/GettingStartedGuide/Tutorial/Step5CreateAComprehensiveDesign.htm

     

    Fails while running Step 4.

     

    DB crashes completely and needs to be restored to previous valid epoch.

    It only happens when including supplied example .sql files in design.

    When not including those .sql files, then it doesn't crash.

     

    * OS: Ubuntu 14.04

    * Machine: AWS m3.medium

    * Storage: 30 GB

    * RAM: 3.7 GB

    * Swap: 4 GB

     

    The same happens on VirtualBox VM with RedHat Linux.

     

  • DB crashes completely and needs to be restored to previous valid epoch.

    It only happens when including supplied example .sql files in design.

    When not including those .sql files, then it doesn't crash.

     

  • I have managed to repeat the same issue on different machines, different setups, different OS.

    It's all the same.

     

    Here's how it looks when ran from Management Console.

     

    Machine:

    - PowerEdge R200
    - Intel Xeon Quad-Core X3220
    - 8GB Memory
    - 2x 128Gb SSD
    - Debian 7.x x64

    - Data: 1 mio rows in 4 tables.

     

    On the HPE example this time it didn't crash, but as soon as I am analyzing my schema, it crashes.

     

    Please, adise, why this might be happening, and how to avoid it?

     

     

  • Today the same problem happened again. In the query file I added a semicolon at the end of the query and that fixed the issue.

  • skamatskamat Administrator

    Can you please paste sample query file that crashed ?

  • You have to have a log files in the path you gave for the designer output to be put in step 1. Get this log

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.