vsql limit

sreeblrsreeblr - Select Field - Employee

vertica sql spool limit
I am trying to create dump of table using vsql -vsql -U  -w  -F "|" -P footer=off -AXnqc "select * from USER_SLCT" > USER_SLCT.csv
The table has 7 million rows but the output of the above shows only 1.79 million. Is there any limit in vsql?



    Why do you have the extended formatting enabled? Also, you dont need to specify -P footer=off. Just add t after the A option. You don't need -F '|'. It's the default separator anyways. 


  • sreeblrsreeblr - Select Field - Employee

    i did try but issue is not with format but the vsql stopping spooling rows after 1.79 million rows while i have  7 million in the file. Hence asking if there is any limit

  • What OS are you running on? 

  • sreeblrsreeblr - Select Field - Employee


  • what's the ouptut of ulimit -a?

    Whats's the size of the file you get when you try to dump the table?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file