Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

vsql:command not found error

edited February 2017 in General Discussion

Hi , i have installed vertica successfully on my ec2 instances (vertica 8.0 )
but when i run vsql i get the following error
[[email protected] bin]# vsql -U dbadmin
-bash: vsql: command not found

please help. why am i getting this error in-spite of successful installation.

Completing installation...

Running upgrade logic
No spread upgrade required: /opt/vertica/config/vspread.conf not found on any node
Installation complete.

Please evaluate your hardware using Vertica's validation tools:
https://my.vertica.com/docs/8.0.x/HTML/index.htm#cshid=VALSCRIPT

To create a database:
1. Logout and login as mydba. (see note below)
2. Run /opt/vertica/bin/adminTools as mydba
3. Select Create Database from the Configuration Menu

Note: Installation may have made configuration changes to mydba
that do not take effect until the next session (logout and login).

To add or remove hosts, select Cluster Management from the Advanced Menu.

Comments

  • you should connect as dbadmin ( do a sudo - dbadmin)

    or you need to call it with the full path and specify the user

    /opt/vertica/bin/vsql -U <>

    However, it is not clear if you used admintools to create a database? If you don't have a database running then vsql won't work but it will print you a message that there is not db running.

    Hope this helps.
    Eugenia

  • Thanks @emoreno ,
    got it..
    i have downloaded the Enterprise edition, and its asking for a license , since we are doing it in a dev environment we would want to go with the community edition so is it possible to modify now to the community edition by running again the installation script.
    I am actually at the page where it is asking me to enter the license file pathname.

  • you don't need to change the license with the install script, you can do it in admintools in the advance menu.

    The license is a text file, the community license you can find it in /opt/vertica/config/licensing/vertica_community_edition.license.key

    You can use as path and when you have the EE license just replace the file.

    Does make sense?
    Eugenia

  • @ emoreno , yeah, Thanks!

  • edited February 2017

    @emoreno I am unable to create a database.
    Could you please tell me why i am getting this error and how should i resolve this
    I have attached the image of the error and below are the logs. What does the permission error mean? is it because mydb (username) is not a able to access the other hosts?

    2017-02-13 17:33:16.405 admintools/41999:0x7f3dd2e89740 [prepare_database.get_user_message] Formatting hint [Permission Denied] for result: host 10.103.2.114 msg [ status=2 host=10.103.2.114 error_type= error_message=Access Denied. Message [Errno 13] Permission denied: '/var/vertica/catalog/mydatabase'

        Stack Trace from Executor follows
    

    Traceback (most recent call last):
    File "/opt/vertica/share/eggs/vertica/engine/api/at_runner.py", line 37, in exec_module
    result = instance.execute(command)
    File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/engine/api/prepare_database.py", line 115, in execute
    return self._execute_impl(cmd, result)
    File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/engine/api/prepare_database.py", line 130, in _execute_impl
    self._make_all_db_dirs(node, result)
    File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/engine/api/prepare_database.py", line 155, in _make_all_db_dirs
    "Access Denied. Message {0}".format(e))
    ATDBPrepareError: Access Denied. Message [Errno 13] Permission denied: '/var/vertica/catalog/mydatabase'

  • @emoreno fyi , the db was not created since i selected a different host. Solved it by selecting the correct host.
    Thanks

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.