Can't stop database via admintools


I've upgraded vertica from 7.1 to 7.2.3. My Vertica version is Vertica Analytic Database v7.2.3-9.

I would like to upgrade it to 8.0 (CE). Unfortunately when I try to stop my database via admintools (4. Stop Database) on the node (one node cluster) I am getting following error:

Error: Unable to connect to database.
Hint: Check authentication.

The other thing is when I choose another option (2. Connect to Database) I am able to login to database by providing the same password.

I've checked the logs in the /opt/vertica/log/adminTools.log and I have found following:

2017-05-12 09:08:19.944 at_exec/80077:0x7fa8a0e0f700 [vsql.connect] Exception when connecting: Error! pty.fork() failed: out of pty devices
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/network/vsql.py", line 174, in connect
self.pexpectConnection = pexpect.spawn(self.getExecuteVsql(), env=self.envVars)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/utils/pexpect.py", line 429, in init
self._spawn (command, args)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/utils/pexpect.py", line 537, in _spawn
raise ExceptionPexpect('Error! pty.fork() failed: ' + str(e))
ExceptionPexpect: Error! pty.fork() failed: out of pty devices

Could you please do let me know how can I safely stop the database ?


  • Options

    Hi wlodi83,

    this is OS error. Please check your pty setting in /etc/sysconfig.conf.

    You may have a look to file, to know your current settings


    Additionally, also check for /var/log/messages to see what is happening with pty.


  • Options

    I have following:
    cat /proc/sys/kernel/pty/nr
    cat /proc/sys/kernel/pty/max

    There is nothing in /var/log/messages which refer to such error.

  • Options

    I already increased pty but that didn't help. I am getting the same error.

  • Options
    emorenoemoreno Employee

    From the vsql prompt try to do select shutdown(); and see if the database comes down. You can tail -f vertica.log and see what is doing.

    Not sure why admintools can not connect to it but if you properly shutdown the database you could update the db and that will set all the settings right again.

  • Options

    Is there any risk by running shutdown() command? Possible data loss?

  • Options
    emorenoemoreno Employee

    No, it will do a proper shutdown, if there is any problem it will let you know. Admintools does the same thing with the difference that SSH the box and execute the shutdown command.

    You can read this doc to ensure that the showdown is down properly


  • Options

    Hi Eugenia,

    thank you! That solved my problem. I was able to stop database by using command: SELECT SHUTDOWN();

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file