Please take this survey to help us learn more about how you use third party tools. Your input is greatly appreciated!

Vertica 8.1 : ConnectionLoadBalance=true in URL disables logging to query_requests table

I am trying to migrate from Vertica 7.2.3 to 8.1 and during the process I noticed that my queries are not being logged into query_requests table, and hence nothing showed in MC query monitoring either. My application connects to Vertica through URL which has in its query string a parameter ConnectionLoadBalance=true.

I discovered this through experimentation and wonder what may I do on my side to assure that I can both retain the above mentioned load-balancing parameter in the URL and have the queries logged/entered into the query_requests table.

Thanks!
NYgenomer

Answers

  • Similarly, the same happens if connection does not go through JDBC, but using vsql.

    When I run the following:

    echo "SELECT count(*) from mySchema.tableName" | ./vsql -h -U -w -d -C --enable-connection-load-balance

    and then look into latest queries in table query_requests I don’t see that the above query being logged.

    However, if I omit the option for load balancing and use the following, the query is logged.

    echo "SELECT count(*) from mySchema.tableName" | ./vsql -h -U -w -d

    To my knowledge and according to the documentation, load balancing requires to be “enabled” both on server and client side, hence whether we use --enable-connection-load-balance in vsql or ConnectionLoadBalance=true in JDBC it is required for proper load balancing. However, queries are not logged into query_requests table when load balancing is fully enabled.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file

Can't find what you're looking for? Search the Vertica Documentation, Knowledge Base, or Blog for more information.