Cannot allocate sufficient memory for COPY statement

I Have a system with high volume data load and I get this error:
Cannot allocate sufficient memory for COPY statement (269484032 requested, 268435456 permitted)
how can I handle that ?


  • Options

    you can split your data file.
  • Options

    how can I increase memory allocated for copy

  • Options

    A caveat: I'm not sure I'm on the right track with this answer:

    Who is running the COPY command? dbadmin?

    What resource pool is the user running the COPY command in? You'll want to see how much memory is allocated (or not) for that pool.

    To answer your question, you can increase the amount of memory allocated to COPY by figuring out what pool it's running in and seeing what it has allocated. This is a broad topic and my answer is, I'm sure, inadequate.

    You'll want to see if MAXMEMORYSIZE is set on the pool, or if MEMORY_CAP_KB is set on the user running the command.

    Have you reviewed the resource_rejections and resource_rejection_details system tables for more information on the error?

  • Options
    edited August 2017

    I use kafka with vertica and the pool is 'kafka_default_pool'
    I'm sure my copy command runs with this pool
    this is kafka_default_pool configuration:

    so what properties should I change for that ?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file