Not able to add ApiKey during import database in management console

TKooiTKooi Registered User

I am taking over the administration of three Vertica databases from our external partner.
It is a vertica 7.1. database

I am not able to use the Management Console for our test and pre-production databases. (Production is working).

The pre-production database are up and running (admintools host ALL Status UP)
I have started the vertica_agent.
(ps -ef | grep vertica -->
a 11448 1 0 14:50 ? 00:00:00 /bin/bash /opt/vertica/agent/agent.sh /opt/vertica/config/users/vertica/agent.conf
vertica 11455 11448 0 14:50 ? 00:00:10 /opt/vertica/oss/python/bin/python ./simply_fast.py
)
I am afraid installations on the db-servers are not standaard.
After starting management console I go to --> Databases and Clusters
Then I go to Import and I add the IP-address of the host.
Error message:
Missing VerticaApiKey. Make sure the Vertica agent is running on all nodes in your cluster

During Administrator training I learned to get the ApiKey from the file .../config/apikeys.dat
But in my case the MC-window to enter the key during database import is not displayed by the wizzard.

How can I add the master key to the management console manually or how can I force the MC to display the window to enter the ApiKey?

Kind regards,
Tom (ONVZ)

Comments

  • Jim_KnicelyJim_Knicely Employee, Registered User, VerticaExpert

    Hi,

    Couple of thoughts ...

    • Make sure the agent is running on each node (not just the node you are providing the IP address). Use the "/etc/init.d/vertica_agent restart" command to restart the agent.
    • Check that the agent will start if a node reboots with the "chkconfig --list vertica_agent" command
    • If you run the command "apikeymgr --list" do you see the expected master API key on each node?
    • After a cluster is imported, you can click on the "Infrastructure" button, then on cluster itself, then on the "API Key" button to re-enter a key
  • TKooiTKooi Registered User

    Hi Jim,
    Thanks a lot for your reaction. I really appreciate it.
    We only have one node so that is making it easy.
    I stopped the database.
    I checked vertica_agent (ps -ef | grep vertica)
    vertica_proces was stil running
    I stopped the vertica_agent sudo /etv/init.d/vertica_agent stop
    checked if vertica_agent was running. It was not

    [vertica@pthdb-a-l01:/opt/vertica/config]$ chkconfig --list vertica_agent
    vertica_agent 0:off 1:off 2:off 3:on 4:on 5:on 6:off
    [vertica@pthdb-a-l01:/opt/vertica/config]$ apikeymgr --list
    Listing 1 keys
    master vertica verylongkeystring admin

    I started the database with admintools
    I started the vertica_agent with sudo /etc/init.d/vertica_agent start

    It's all running fine.

    Then you mention ........ After a cluster is imported
    Here starts my problem. If I use import I end with an error and no cluster:

    I have two options after I selected tab "Databases and Clusters" in the managementconsole.

    • Import --> folowed by a window to enter the IP-adres of the vertica server
    • Create Cluster --> followed by a screen to enter clustername etc.

    Do I have to create a new cluster? During the administartor training we just clicked "Import" --> enter ip_address --> next --> and then add the ApiKey.
    This option Add Apikey is not given ?

    Kind regards,
    Tom

  • Jim_KnicelyJim_Knicely Employee, Registered User, VerticaExpert

    Yeah, you should be doing:

    "Import" --> enter ip_address --> next --> and then add the ApiKey.

    Can you verify the version of MC and Vertica? The API key wasn't introduced until 7.1. You mentioned the Vertica DB is 7.1, but verify that MC is also 7.1.

    Example:

        [dbadmin@s18384357 ~]$ rpm -qa | grep -i vertica
        vertica-8.1.1-5.x86_64
        vertica-console-8.1.1-0.x86_64