rsync error while backup vertica db

[user_testing@localhost ~]$ /opt/vertica/bin/vbr.py -t init -c /home/user_testing/vertica_backup.ini 

103.*.*.* /opt/vertica/oss/python/bin/python -V || true
Transfer Server process entry: pid 330550.
Acquiring remoteServer mutex.
Acquired remoteServer mutex.
ps aux | grep rsync | grep -v grep | grep daemon | grep port=50000

A new Rsync daemon has started.
Released mutex.

Initializing backup locations.
Error: Error accessing remote storage: failed accessing remote storage on 103.*.*.*: rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
rsync error: error in rsync protocol data stream (code 12) at io.c(601) [Receiver=3.0.7]
: returncode=12

Plz provide solution.I'm struck


  • Options


    Check that remote path exists. You can get error code 12 if you specify a remote path that doesn't exist.

  • Options

    where I have to specify that remote path correctly ??

  • Options
    Jim_KnicelyJim_Knicely - Select Field - Administrator
    edited February 2018

    @ashu123 - In the mapping section of the vbr ini file:


    ; !!Mandatory!! This section defines what host and directory will store the backup for each node.
    ; node_name = backup_host:backup_dir
    ; In this "parallel backup" configuration, each node backs up to a distinct external host.
    ; To backup all database nodes to a single external host, use that single hostname/IP address in each entry below.
    v_exampledb_node0001 =
    v_exampledb_node0002 =
    v_exampledb_node0003 =
    v_exampledb_node0004 =

    In the example, the backup directory is /home/dbadmin/backups.

    If your backup directory does not exist on 103...* , did you run vbr --task int?

    init — Creates a new backup directory, or prepares an existing one, for use and creates necessary backup manifests. You must perform this task before the first time you create a backup in a directory.


  • Options
    edited February 2018

    hello @Jim_Knicely
    This is my vbr.ini file

    snapshotName = vertica_backup
    restorePointLimit = 1
    objectRestoreMode = createOrReplace
    tempDir = /tmp/vbr
    retryCount = 5
    retryDelay = 3
    passwordFile = pwdFile

    dbName = database
    dbUser = user
    dbPromptForPassword = True

    encrypt = False
    checksum = False
    port_rsync = 50000
    serviceAccessUser = asha
    total_bwlimit_backup = 0
    concurrency_backup = 1
    total_bwlimit_restore = 0
    concurrency_restore = 1

    v_db_testing_0_node0001 = 103.*.*.*:home/asha/backup/

    Again getting same error :(

  • Options

    If I run vbr init command, the following rsync command is being prepared.

    /opt/vertica/bin/rsync -s --list-only -d rsync://[103...*]:50000/vbr//home/asha/backup/backup_manifest

  • Options
    edited February 2018


    v_db_testing_0_node0001 = 103.*.*.*:home/asha/backup/

    path incorrect(no slash / in the beginning.), should be

    v_db_testing_0_node0001 = 103.*.*.*:/home/asha/backup/

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file