set frame_duration for Kafka integration

I successfully made a scheduler to consuming data from kafka.
when I launch my scheduler and query v_monitor.query_request, duration is always 0 millisecond in KafkaSource parameters.

I tried set frame_duration (and config_refresh) using following command :

/opt/vertical/packages/Kafka/bin/vkconfig scheduler --update --config-schema kScheduler --frame-duration 00:03:00 --username dbadmin --password A

it changes frame_duration value but when I query stream_scheduler , frame_duration is 2810 days and 19 hours!

I tried set this value inside single quotations to but no luck !

finally I tried set frame_duration manually with an update statement :
UPDATE kScheduler.stream_scheduler SET frame_duration = '3 mins';

it changes but and query result seems fine but still duration is 0 !

In stream_events: received configuration details; frame duration: -1960735872, refresh interval: -1787935852

and always OVERSHOT DEADLINE FOR FRAME -- remaining time (ms): - 1960........

what's wrong ?


  • Options
    Vertica Analytic Database v9.0.1-0
    Vertica Streaming Load Scheduler v9.0.1-0
    Configuration Schema Version v8.1.1

    I tried to upgrade scheduler with following command:
    /opt/vertica/packages/Kafka/bin/vconfig scheduler --upgrade --username dbadmin --password A

    Checking if UPGRADE necessary...
    Upgrade is not required, the current scheduler configuration Schema version is already up-to-date: v.8.1.1

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file