increasing thread_count on Vertica

Hi All,

     I have a Vertica query running in a separate resource pool. The query is using a UDAF

to aggregate 500 Million records, it is taking more than 6 hours to complete. Upon checking
RESOURCE_POOL_STATUS, I found that the query is using only 8 threads and 0.5 MB
memory per node. I configured the resource pool to use EXECUTION_PARALLELISM=32
As I there are 32 cores on each node.

However, Vertical doesn’t honour the settings requested and continuous with only 8 threads, with 6 hours execution time.

How can we configure Vertica, to use more memory, threads, and CPU to run much faster?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file