Rejected Reason: Too Many Columns Found

BWCempl237BWCempl237 Community Edition User

When I try to copy a file from my local drive the majority of records are not copying with the rejected reason: too many columns found. I am trying to copy the exact same columns from the file, though, into the table. Has anyone encountered this error before or know what it means?

Best Answer


  • Options
    SruthiASruthiA Vertica Employee Administrator

    please share sample rows, table definition and your COPY statement.

  • Options
    moshegmosheg Vertica Employee Administrator

    In addition, try to use unprintable character as a delimiter, to eliminate the risk that your data include a delimiter character.
    The following examples use \001 (CTRL-A) as field separator and \002 (CTRL-B) as record separator.
    Export 2000 rows from a table to a file:
    vsql -F $'\001' -R $'\002' -P null='REALNULL' -AXtnqc "select * from schema_name.table_name limit 2000" > file_name.tbl
    Load the file data back to a table:
    copy schema_name.table_name from 'file_name.tbl' delimiter E'\001' record terminator E'\002' null 'REALNULL' abort on error;

  • Options
    BWCempl237BWCempl237 Community Edition User

    Enclosed by ' " ' command was what I was missing LenoyJ, thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file